16 M flash ChaosCalmer

kannan
 
Posts: 1
Joined: Wed Feb 24, 2016 2:34 am

16 M flash ChaosCalmer

Wed Feb 24, 2016 2:43 am

HI,

I downloaded a CC vocore version from http://downloads.openwrt.org/chaos_calm ... ps/rt305x/ and flashed my VoCore. it is working fine. however, the df shows only 8M of memory??
root@OpenWrt:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 4.5M 300.0K 4.2M 7% /
/dev/root 2.3M 2.3M 0 100% /rom
tmpfs 14.3M 1.1M 13.2M 8% /tmp
/dev/mtdblock6 4.5M 300.0K 4.2M 7% /overlay
overlayfs:/overlay 4.5M 300.0K 4.2M 7% /
tmpfs 512.0K 0 512.0K 0% /dev


Is there any patch available to extend to 16M without going through the whole recompilation process?
is there any specific reason why this is not available in mainstream release?

thanks
kannan

Vonger
 
Posts: 754
Joined: Sun Oct 19, 2014 6:00 am

Re: 16 M flash ChaosCalmer

Thu Feb 25, 2016 3:41 pm

Hi,
It is partition, please modify VOCORE.dts in openwrt source code, update 0x7b000000 to 0xfb000000

tippy2k
 
Posts: 2
Joined: Fri Feb 26, 2016 10:20 pm

Re: 16 M flash ChaosCalmer

Fri Feb 26, 2016 10:38 pm

Is there any patch available to extend to 16M without going through the whole recompilation process?


Yes, you can quickly do this with the OpenWRT Image builder.
https://wiki.openwrt.org/doc/howto/obtain.firmware.generate

To build a custom image for your vocore from pre-compiled binaries you need to download this package:
https://downloads.openwrt.org/chaos_calmer/15.05/ramips/rt305x/OpenWrt-ImageBuilder-15.05-ramips-rt305x.Linux-x86_64.tar.bz2

After you unpack the files. You need to modify this file:
target/linux/ramips/dts/VOCORE.dts

Change 0x7B0000 to 0xFB0000

After the change is made you can build a new image with this command:
$ make image PROFILE=VOCORE PACKAGES="luci"

The build should very quick. Be sure to configure the repositories and to add whatever software you want like Luci.

Upgrade using this generated file:
bin/ramips/openwrt-15.05-ramips-rt305x-vocore-squashfs-sysupgrade.bin
DO NOT let your config files be overwritten during the upgrade.

After you upgrade you can ssh to the vocore. If you forgot to add luci install it like this:
Code: Select all
opkg update
opkg install luci


I hope this helps you.

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: No registered users and 1 guest