Failure to build image: root.ubifs': No such file

Posts: 1
Joined: Sat Nov 28, 2015 10:59 pm

Failure to build image: root.ubifs': No such file

Sun Nov 29, 2015 6:15 am

Does anyone know how to correct a problem I'm having with setting up and compiling vocore openwrt?

I've tried on MacOSX and Ubuntu Linux 14.04 with the same error result.

LZMA 4.65 : Igor Pavlov : Public domain : 2009-02-03
mkimage -A mips -O linux -T kernel -C lzma -a 0x80000000 -e 0x80000000 -n "MIPS OpenWrt Linux-3.18.23" -d /home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/vmlinux-vocore-16M.bin.lzma /home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/vmlinux-vocore-16M.uImage
Image Name: MIPS OpenWrt Linux-3.18.23
Created: Sat Nov 28 22:17:32 2015
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 1171353 Bytes = 1143.90 kB = 1.12 MB
Load Address: 80000000
Entry Point: 80000000
cat /home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/vmlinux-vocore-16M.uImage /home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/root.squashfs > /home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/openwrt-ramips-rt305x-vocore-16M-squashfs-sysupgrade.bin
/home/mark/openwrt/openwrt/staging_dir/host/bin/padjffs2 /home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/openwrt-ramips-rt305x-vocore-16M-squashfs-sysupgrade.bin 4 8 16 64 128 256
padding image to 00300000
if [ `stat -c%s "/home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/openwrt-ramips-rt305x-vocore-16M-squashfs-sysupgrade.bin"` -gt 16449536 ]; then echo "Warning: /home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/openwrt-ramips-rt305x-vocore-16M-squashfs-sysupgrade.bin is too big" >&2; else cp -fpR /home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/openwrt-ramips-rt305x-vocore-16M-squashfs-sysupgrade.bin /home/mark/openwrt/openwrt/bin/ramips/openwrt-ramips-rt305x-vocore-16M-squashfs-sysupgrade.bin; fi
dd if=/home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/root.ubifs of=/home/mark/openwrt/openwrt/bin/ramips/openwrt-ramips-rt305x-root.ubifs bs=128k conv=sync
dd: failed to open '/home/mark/openwrt/openwrt/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/root.ubifs': No such file or directory

Posts: 812
Joined: Sun Oct 19, 2014 6:00 am

Re: Failure to build image: root.ubifs': No such file

Sun Nov 29, 2015 9:05 am

Hi, maybe use openwrt source 14.07 could fix it

Posts: 240
Joined: Sat Nov 29, 2014 3:22 pm

Re: Failure to build image: root.ubifs': No such file

Mon Nov 30, 2015 11:34 pm

I have run into that for the last couple of weeks when using openwrt trunk. This is a new image format using ubifs instead of jffs. You can turn it off in the make menuconfig step under Target Images. It is a bit aggravating that is it turned on by default though.

As Vonger states you can avoid trouble with new features by using a stable version of OpenWrt. Either Barrier Breaker (14.07) or Chaos Calmer (15.05) should have far fewer problems. This page shows how to get them.

Here is what Wikipedia says about ubifs:
The Unsorted Block Image File System (UBIFS) is a successor to JFFS2, and competitor to LogFS, as a file system for use with raw flash memory media. Development began in earnest in 2007, with the first stable release made to Linux kernel 2.6.27 in October 2008.

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: Bing [Bot] and 5 guests