I2C Basic Setup

danie
 
Posts: 5
Joined: Thu Dec 03, 2015 4:32 am

I2C Basic Setup

Thu Dec 03, 2015 4:51 am

I would like to use I2C on a LPS331AP sensor IC. I am struggling with I2C on the Vocore.

Can somebody perhaps post a simple recipe to setup I2C on the Vocore ? I am a beginner with OpenWrt and Linux.

My connections are: (not sure if this is correct)

BOARD VCC -> VoCore 3.3V
BOARD GND -> VoCore GND
BOARD SCL -> VoCore G#02/I2C_SCLK
BOARD SDA -> VoCore G#01/I2C_SD

I have a white Vocore v1.0 and Linux command uname -a reports:

Linux OpenWrt 3.10.49 #4 Tue Sep 15 22:04:56 EDT 2015 mips GNU/Linux

Vonger
 
Posts: 733
Joined: Sun Oct 19, 2014 6:00 am

Re: I2C Basic Setup

Thu Dec 03, 2015 1:57 pm

I think you forget the pull up 4.7Kohm resistor for I2C CLK and I2C DAT. :mrgreen:

danie
 
Posts: 5
Joined: Thu Dec 03, 2015 4:32 am

Re: I2C Basic Setup

Sun Dec 06, 2015 4:20 pm

hey i got my i2c working ! here is the recipe:

1. load latest firmware ie 3.18.20 ; use web interface , it works well
2. enable internet for AP + STA ; use Vonger's recipe
3. opkg update
4. change passwd for good measures :-)
5. copy i2c tools over from openwrt repository with pc (to pc hard disk)
6. Use WinSCP to copy these files to /root on vocore
7. opkg install <filenames> {to install the i2c packages)
8. check now i2c devices: ls /dev/i*
9.check the LPS331AP device: i2cdetect -r 0
10. load data from sensor: i2cdump -y 0 0x5d

there is it !! thanks to all those who helped me :-)

ps the Pololu LPS331AP has pull-ups and everything. that was not the issue.

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: Bing [Bot] and 2 guests