Adventures with vocore

bwatt
 
Posts: 2
Joined: Thu Dec 03, 2015 9:00 pm

Adventures with vocore

Thu Dec 03, 2015 9:20 pm

Hello,

Just got started with the vocore yesterday. Its a cool little device.

Anyways, so my adventure began with the desire to be able to plug in a USB thumbdrive to be able to load or host some programs.
Plugging one in seemingly did nothing.
Tried following the instructions I have found on the forum in various locations, on the openwrt pages etc.

Was getting an error about prequisites not met (sorry i forget the actual message).. Anyways one post suggested re-building the firmware.
(so i have a vm building the firmware.. been doing somthing for at least an hour now... )

then i saw this post
viewtopic.php?f=2&t=380&p=1296&hilit=storage&sid=e1332424e4867ec66478a3a3435b185f#p1296

So i ran these commands..
cd /tmp
wget http://noblepepper.com/wp/wp-content/Vo ... pgrade.bin
sysupgrade openwrt-ramips-rt305x-vocore-squashfs-sysupgrade.bin

and the thing rebooted, but then took a while before it came back up. I thought i bricked it.
Eventually, i was able to get it back up. But now the link lights on my ethernet connection don't actually light up anymore.
...
anyways, does anyone have any insight as to
A. get things back to normal if i've screwed it all up, and
B get the original plan to work, with the USB as a storage device.

I normally consider myself to be pretty tech savvy, and am looking at this device as a home for a project that I got working on a raspberry pi.
But this has been frankly a humbling experience trying to figure this out. Havn't played with openwrt before, or creating firmware etc.

As I read through the forum, I can't help be get the impression that many simple errors that are encountered by noobs would be something easily fixed by a person with more experience.

Any suggested resources that you could point me to, to give me a bit more of an overview of some parts of the process would be fantastic.

Thanks in Advance
Brandon

Vonger
 
Posts: 659
Joined: Sun Oct 19, 2014 6:00 am

Re: Adventures with vocore

Fri Dec 04, 2015 1:23 am

Hi, I think you are using dock v1.0 firmware, the ethernet light control is not same, please download http://vonger.cn/upload/firmware/vocore.dock2.bin to recover from uboot.

Another way to fix it, nobblepepper version should work too, but might did not enable wifi, just use uart go in it enable wifi, and sysupgrade again

bwatt
 
Posts: 2
Joined: Thu Dec 03, 2015 9:00 pm

Re: Adventures with vocore

Fri Dec 04, 2015 2:45 pm

Hi,

Thanks, the dock v1.0 firmware you suggested is working again now.

Is there a way to connect uart with the dock still attached? Or do i have to remove the dock to make the connections?

Thanks

Vonger
 
Posts: 659
Joined: Sun Oct 19, 2014 6:00 am

Re: Adventures with vocore

Sat Dec 05, 2015 1:33 pm

Just bend or cut off the place holder in TX and RX holes then connect directly :)

noblepepper
 
Posts: 240
Joined: Sat Nov 29, 2014 3:22 pm

Re: Adventures with vocore

Sat Dec 05, 2015 8:41 pm

You have several things going on, I'll try to hit them separately.

1. Anytime you flash a new firmware image it will take 3 to 4 times longer to boot up the first time, after that you'll be back to the normal ~30 second boot time.

2. If you use sysupgrade it should keep the configuration from before so if your radio was enabled, it should stay that way. If you use uboot you will have the settings in the image when it was compiled.

3. As Vonger says a lot of images have the radio disabled by default. You have to have access to the serial console to enable it. I use uci to change this. If you enter
Code: Select all
uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.channel='11'
wireless.radio0.hwmode='11g'
wireless.radio0.path='10180000.wmac'
wireless.radio0.htmode='HT20'
wireless.radio0.disabled='1'
wireless.radio0.txpower='20'
wireless.radio0.country='00'
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device='radio0'
wireless.@wifi-iface[0].ssid='xxxxxxxx'
wireless.@wifi-iface[0].mode='sta'
wireless.@wifi-iface[0].network='lan wwan'
wireless.@wifi-iface[0].encryption='psk2'
wireless.@wifi-iface[0].key='xxxxxxxxxx'
in the console, you want to change the disabled setting. You can
Code: Select all
uci set wireless.radio0.disabled='0'
uci commit
/etc/init.d/network restart
and the vocore will start an access point you can connect to with ssh or a web page if Luci was built into the image. I try to have the radio enabled and include Luci when I build images but these are easy to forget ;-)

4. I love how small the vocore is but the size requires the 0.1 mm pin spacing and they can be a pain in the ass. The best solution I have found is to solder a male/female header on the vocore and then use jumpers soldered to a short piece of male/male header to connect to the serial/USB adapter.

5. If you try to install packages that were not built in the same run as the base image you can run into dependencies problems. I put together the Chaos Calmer rc1 image and package repository so they would match but now there is an final release that would serve you better. You can get it here and it should be set up to use compatible packages.

6. Once you get a stable image/package repository setup the instructions you tried to follow before should work fine.

7. I started a wiki that you may find useful in getting familiar with the vocore/openwrt.

8. Openwrt runs on incredibly small hardware and has a hardcore and very capable group maintaining it. A Rasberry pi is a bloated waste of hardware from their perspective. They can be brusque, my first question on the irc channel asking if someone would help me with a configuration issue was answered with "don't ask to ask". Polite niceties can be seen as noise. There is a lot of info on OpenWrt.org but some of it is out of date, don't be surprised if something doesn't work.

Return to VoCore & VoCore+dock

Who is online

Users browsing this forum: No registered users and 3 guests