Vocore Upgrade

cw5301
 
Posts: 3
Joined: Sun Mar 13, 2016 7:37 pm

Vocore Upgrade

Sun Mar 13, 2016 7:46 pm

Hi...

I'm hoping to use quite a few Vocores for a "IOT" project... but there are problems with the Openwrt image.

Openwrt apparently deleted the "Barrier Breaker" archives, so I upgraded to Chaos Calmer.

But many of the executables in the current Openwrt packages are not binary compatible with the version of Chaos Calmer for Vocore. I get "file not found" errors, or when I install older binaries, it breaks compatibility with many of the system libraries (like libc).

Also: the system partition is only 4.6M and most of the system space is under /tmp, so there isn't enough room to install the packages needed.

I am working on compiling my own version of Openwrt but am afraid that will create more problems than it solves.

Any advice is appreciated... I would like all the storage under the root partition and need to get an OS image that is compatible with the current packages...

Thank you,

CW

noblepepper
 
Posts: 240
Joined: Sat Nov 29, 2014 3:22 pm

Re: Vocore Upgrade

Wed Mar 16, 2016 10:19 pm

Any advice is appreciated...
You should really learn to research your questions before posting, these all have been answered before. You will usually get better answers if you ask one question per post that you have tried to find the answer and couldn't. When you have compatibility issues you need to specify- What exact image it happens on, what you are trying to install, the exact command you used, the exact error you received. cut and paste is best so typos don't creep in. The URL tool in the bar above the editing window is very useful for this (examples below, in my browser they are highlighted in green) too

Openwrt apparently deleted the "Barrier Breaker" archives, so I upgraded to Chaos Calmer.
The openwrt people have been fighting some server issues lately, they appear to be working now.

But many of the executables in the current Openwrt packages are not binary compatible with the version of Chaos Calmer for Vocore. I get "file not found" errors, or when I install older binaries, it breaks compatibility with many of the system libraries (like libc).
Not specific enough to know exactly which versions or packages you are talking about but probably related to this

Also: the system partition is only 4.6M and most of the system space is under /tmp, so there isn't enough room to install the packages needed.
http://forum.vocore.io/viewtopic.php?f=10&t=1969&p=3177&hilit=8M+16M&sid=de9f22b746382072ee588982308e758c&sid=de9f22b746382072ee588982308e758c#p3177
You either need to compile your own image or use one from Vonger to get BB or CC with access to full flash available. The latest openwrt trunk has both a 8M and 16M image.

I am working on compiling my own version of Openwrt but am afraid that will create more problems than it solves.
Not hard at all here is step by step tutorial

I would like all the storage under the root partition and need to get an OS image that is compatible with the current packages...
What do you mean by current? All packages in a particular repository should work to together fine - BB, CC, or DD

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: Majestic-12 [Bot] and 5 guests