Page 1 of 1

Wifi client microHOWTO

Posted: Sat Nov 08, 2014 12:16 pm
by Daxer
I'm sure i'm not alone who want to make vocore become wifi client in their home network. But if you miss something you lost connection to vocore at all.
Now I write several steps to config wificlient on vocore and i hope it will help someone.
1. Let's see default config. First you should ssh you vocore. Then edit /etc/config/wireless in the way like that:
config wifi-device 'radio0'
option type 'mac80211'
option channel 'auto'
option hwmode '11g'
option path '10180000.wmac'
option txpower '20'
option htmode 'HT40'
option country 'RU'

config wifi-iface
option device 'radio0'
option network 'wlan0' # name of new interface
option mode 'sta' # client mode
option ssid 'daxwifi2' # ssid of you home network
option encryption 'psk2'
option key 'password' # change to tou wifi password

Then add to /etc/config/network

config interface wlan0
option proto 'dhcp'

And finally
/etc/init.d/network restart

if you do everything right vocore connect to your homenet

Re: Wifi client microHOWTO

Posted: Mon Nov 10, 2014 7:31 am
by silviop
--But if you miss something you lost connection to vocore at all

I suppose that there is a safe boot default pin in vocore
http://wiki.openwrt.org/doc/howto/generic.failsafe

but i don't' find it in wiki.

Re: Wifi client microHOWTO

Posted: Mon Nov 10, 2014 7:42 pm
by AR560
--But if you miss something you lost connection to vocore at all

How about no?
You can also connect via uart tty terminal

Look at 6 page:
http://vonger.cn/upload/vocore.manual.pdf

Re: Wifi client microHOWTO

Posted: Thu Nov 20, 2014 6:48 pm
by Daxer
Yes, you are right. I mean you lost network connection. UART will work.

Re: Wifi client microHOWTO

Posted: Thu Nov 20, 2014 6:55 pm
by Peter H
The Ethernet interface is configured in the WAN zone by default so you can't use it to manage the VoCore. I recommend moving it to the LAN zone first (and check you can connect by SSH and HTTP) before you risk playing with the WiFi settings.

If you have established a serial connection, that gives you another option to get back into the VoCore if you break the WiFi configuration, but I found it far easier to get the WiFi configuration working through the web interface.

Re: Wifi client microHOWTO

Posted: Sat Nov 29, 2014 2:53 am
by contractorwolf
peter h - can you explain how to best switch the Ethernet Interface from WAN to LAN?

Re: Wifi client microHOWTO

Posted: Sat Nov 29, 2014 5:33 pm
by Peter H
The way I found easiest was to establish a WiFi connection so I could log into the LuCI web interface, then use the Network menu to open the Firewall configuration page. As standard there are two zones - WAN and LAN. Click the Edit link next to the WAN zone and un-tick the LAN interface (eth0.1) to remove it from this zone. Then edit the LAN zone and tick the LAN interface (eth0.1) to add it to the LAN zone. You should then be able to connect to the web interface and establish SSH connections to the Ethernet interface. Once you've achieved that it's safe to play with the WiFi configuration to change it from AP mode to STA mode so it can associate with your home WiFi network.

Re: Wifi client microHOWTO

Posted: Sat Dec 06, 2014 1:43 am
by pcnate
It took me a while to figure it out on my WPA2 network after I locked myself out and had to resort to a usb to serial connection. I think I screwed up a few wireless settings and couldn't get anything working. What worked was to do the following:

Reset the wireless config I screwed up:
Code: Select all
wifi detect > /etc/config/wireless

At this point you could connect to the AP after restarting the network like this:
Code: Select all
/etc/init.d/network restart


Instead, I wanted my VoCore on the network so I changed the /etc/config/wireless configuration to the following:
Code: Select all
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     '10180000.wmac'
        option htmode   HT20

config wifi-iface
        option device   radio0
        option network  lan
        option mode     sta
        option ssid       mynetwork
        option encryption psk2
        option key 'mypassword'

Re: Wifi client microHOWTO

Posted: Mon Dec 15, 2014 2:27 am
by hdokes
Is more than one SSID wifi network configuration in a client mode allowable? In the event the unit 'roams' can two networks for wifi be configured in a client mode with the ability of the vocore to auto connect to the one it can reach at the moment?