Installation of kmod modules

Chris
 
Posts: 3
Joined: Tue Dec 02, 2014 4:47 pm

Installation of kmod modules

Mon Dec 22, 2014 2:30 pm

I would like to use the firmware released by Vonger, which allows to use the mmc card, but want to compile and install some additional kernel modules.

I understood from the text appearing at the login that the OpenWRT revision is r42583.

Therefore I checked out the OpenWRT sources from git and compiled them (all went fine):
git clone git://git.openwrt.org/openwrt.git
git checkout 7dd11cd2c8b01e57d0da41247a8c898f9faabe12

The number from the checkout I deduced from the git log command which showed:

--------
commit 7dd11cd2c8b01e57d0da41247a8c898f9faabe12
Author: hauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date:   Tue Sep 16 21:39:24 2014 +0000

    kernel: add missing config option
    
    This missing option was found by the build bots.
    
    Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
    
    
    git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42583 3c298f89-4303-0410-b956-a3cf2f4a3e73
----------

When I now take the kernel modules of my compilation I anyway get dependency problems and the modules do not load. For example when I try to load the compiled kmod-fs-ext4 I get (I put the packages compiled by me on my internal web server on my router (of course also OpenWRT :-):

opkg install kmod-fs-ext4
Installing kmod-fs-ext4 (3.14.18-1) to root...
Downloading http://192.168.0.1/public/vocore/kmod-f ... _24kec.ipk.
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
* kernel (= 3.14.18-1-0fb3f9bd9caf703f5be8cdca365b7bfe) * kernel (= 3.14.18-1-0fb3f9bd9caf703f5be8cdca365b7bfe) * kernel (= 3.14.18-1-0fb3f9bd9caf703f5be8cdca365b7bfe) *
* opkg_install_cmd: Cannot install package kmod-fs-ext4.

Did I check out the wrong version of OpenWRT? How do I check out the correct one (from git)?
Any other suggestion what I am doing wrong, or what I need to do to compile successfully kernel modules for that particular firmware of Vonger? (I know, I could try to flash my own created firmware image... but I wanted to go with minimal risk, given that the firmware of Vonger works...)

Many thanks for any hint!

Vonger
 
Posts: 764
Joined: Sun Oct 19, 2014 6:00 am

Re: Installation of kmod modules

Tue Dec 23, 2014 8:13 am

I think openwrt source code broken in that truck, please use older version.
And compile all the necessary ipk by yourself.
I get the same problem, but no idea how to fix that.

Vonger
 
Posts: 764
Joined: Sun Oct 19, 2014 6:00 am

Re: Installation of kmod modules

Tue Dec 23, 2014 8:56 am

I just recompile the latest openwrt, video works normal, the drivers.
vonger.cn/upload/vocore.16m.noluci.bin

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: No registered users and 1 guest