Second ethernet port not working

ittsmh
 
Posts: 1
Joined: Thu Mar 16, 2017 10:02 am

Second ethernet port not working

Thu Mar 16, 2017 10:41 am

Hi all,
i have a VoCore1 with the original openwrt-image Barrier Breaker and i want use both ethernet ports. I have made a pcb for the vocore and the 2 magnetics required for the 2 ethernet ports.

If i connect vocore ethernet port 4 to an ethernet-switch it takes a few seconds and the link is stable (link-LED on the ethernet-switch is on). Also i can open a ssh-shell from my desktop pc on the vocore over this ethernet link. Everything is working ok.

Doing the same with vocore ethernet Port 0 it is not working.
If i connect vocore port 0 to an ethernet-switch no link-LED on the switch is flashing. No communication is established.
If i reboot then the vocore i can see some link-LED flashing on the ethernet switch but after a few seconds the link-LED is switched of and nothing more happens.

Then i have done a second check.
I have another vocore, a vocore+dock. I have connected the vocore+dock to the ethernet switch. After a few seconds the link-LED is on and i can communicate with this vocore+dock. vocore+dock is using ethernet port 4 of the vocore.
Then i have disconnected the 4 pins of vocore ethernet port 4 from the dock and have connected the 4 pins of vocore ethernet port 0 to the dock.
Rebooted the vocore+dock, some link-LED flashing during bootup, but after a few seconds the link-LED is switched of an no communication to the vocore+dock from my destop-pc is possible.

Can anybody give me a hint what's going wrong?

Thanks
Markus

noblepepper
 
Posts: 221
Joined: Sat Nov 29, 2014 3:22 pm

Re: Second ethernet port not working

Fri Mar 17, 2017 1:37 am

The original image was probably compiled for one Ethernet port, you are going to need to compile your own.

A quick look at vocore.dts and rt5350.dtsi makes me think you may just need a
Code: Select all
status= "okay";
in the esw@10110000 section of vocore.dts since it is set disabled in the dtsi.

Return to VoCore & VoCore+dock

Who is online

Users browsing this forum: Google [Bot] and 3 guests