vocore +Dock(v2) hangs at procd: - preinit -

jperkins
 
Posts: 3
Joined: Thu Jan 11, 2018 12:50 pm

vocore +Dock(v2) hangs at procd: - preinit -

Thu Jan 11, 2018 1:10 pm

I tried to upgrade my vocore +Dock(v2) from openwrt 14.07 to 15.05 from within luci. The upgrade seemed to go fine but after I configured the network from the shell and used 'uci commit' the vocore would not reboot. I used the 'Firmware OpenWrt Install' from here .
https://wiki.openwrt.org/toh/vocore/vocore

Then I tried other images of openwrt but I believe I ran into the issue that the old uboot on the vocore can not handle larger than 4MB as mentioned here. viewtopic.php?f=11&t=1902&sid=3800ec4fd239be97fe5b174f7a53a9c1#p4780

- What I am trying to do now _
I have tried to reinstall the original firmware from uboot as outlined here http://vocore.io/v1d.html ( Fix Bricked VoCore ) The device hangs at -preinit - . eventually the watchdog timer times out and the device reboots.

the image I am trying to flash is http://vonger.cn/upload/vocore.dock2.bin . that is what is currently on the vocore.


So the best I understand is my uboot is working but the vocore will not boot. After I can get the vocore booted up I can then attempt to upgrade the firmware to 15.5 or lede 17.01

I also have verified that my vocore has 16Mib flash as outlined here https://wiki.openwrt.org/toh/vocore/vocore

thanks for your help in getting my vocore working again



Code: Select all
jperkins@htpc:~$ kermit -c
Connecting to /dev/ttyUSB1, speed 57600
 Escape character: Ctrl-\ (ASCII 28, FS): enabled
Type the escape character followed by C to get back,
or followed by ? to see other options.
----------------------------------------------------
...............

   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

[    0.000000] Linux version 3.10.49 (vonger@ubuntu) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r47068) ) #10 Sat Oct 31 13:36:35 CST 2015
[    0.000000] SoC Type: Ralink RT5350 id:1 rev:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0001964c (MIPS 24KEc)
[    0.000000] MIPS: machine is VoCore
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 00800000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x007fffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x007fffff]
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 2032
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 32 (order: -5, 128 bytes)
[    0.000000] Dentry cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Writing ErrCtl register=0001dfaf
[    0.000000] Readback ErrCtl register=0001dfaf
[    0.000000] Memory: 4984k/8192k available (2163k kernel code, 3208k reserved, 557k data, 156k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 360MHz
[    0.000000] Calibrating delay loop... 239.61 BogoMIPS (lpj=1198080)
[    0.070000] pid_max: default: 32768 minimum: 301
[    0.070000] Mount-cache hash table entries: 512
[    0.080000] pinctrl core: initialized pinctrl subsystem
[    0.090000] NET: Registered protocol family 16
[    0.140000] bio: create slab <bio-0> at 0
[    0.150000] rt2880_gpio 10000600.gpio: registering 22 gpios
[    0.160000] rt2880_gpio 10000600.gpio: registering 22 irq handlers
[    0.170000] rt2880_gpio 10000660.gpio: registering 6 gpios
[    0.180000] rt2880_gpio 10000660.gpio: registering 6 irq handlers
[    0.190000] Switching to clocksource MIPS
[    0.200000] NET: Registered protocol family 2
[    0.210000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.230000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.240000] TCP: Hash tables configured (established 512 bind 512)
[    0.250000] TCP: reno registered
[    0.260000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.270000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.280000] NET: Registered protocol family 1
[    0.290000] rt-timer 10000100.timer: maximum frequncy is 7324Hz
[    0.350000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.360000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.380000] msgmni has been set to 16
[    0.390000] io scheduler noop registered
[    0.400000] io scheduler deadline registered (default)
[    0.420000] gpio-export gpio-export.4: 11 gpio(s) exported
[    0.430000] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    0.450000] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20) is a 16550A
[    0.460000] console [ttyS0] enabled, bootconsole disabled
[    0.460000] console [ttyS0] enabled, bootconsole disabled
[    0.500000] m25p80 spi32766.0: found w25q128, expected s25fl064k
[    0.510000] m25p80 spi32766.0: w25q128 (16384 Kbytes)
[    0.520000] 4 ofpart partitions found on MTD device spi32766.0
[    0.530000] Creating 4 MTD partitions on "spi32766.0":
[    0.540000] 0x000000000000-0x000000030000 : "uboot"
[    0.550000] 0x000000030000-0x000000040000 : "uboot-env"
[    0.570000] 0x000000040000-0x000000050000 : "factory"
[    0.580000] 0x000000050000-0x000001000000 : "firmware"
[    0.600000] 0x000000145ad0-0x000001000000 : "rootfs"
[    0.610000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.640000] mtd: device 4 (rootfs) set to be root filesystem
[    0.650000] mtd: partition "rootfs_data" created automatically, ofs=0x370000, len=0xc90000
[    0.660000] 0x000000370000-0x000001000000 : "rootfs_data"
[    0.690000] ralink_soc_eth 10100000.ethernet eth0: ralink at 0xb0100000, irq 5
[    0.710000] rt3xxx-usbphy usbphy.3: loaded
[    0.720000] rt2880_wdt 10000120.watchdog: Initialized
[    0.730000] TCP: cubic registered
[    0.730000] NET: Registered protocol family 17
[    0.740000] 8021q: 802.1Q VLAN Support v1.8
[    0.770000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.790000] Freeing unused kernel memory: 156K (802a9000 - 802d0000)
procd: Console is alive
procd: - watchdog -
[    7.040000] usbcore: registered new interface driver usbfs
[    7.050000] usbcore: registered new interface driver hub
[    7.060000] usbcore: registered new device driver usb
[    8.930000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    8.940000] ehci-platform: EHCI generic platform driver
[    9.150000] rt3xxx-usbphy usbphy.3: remote usb device wakeup disabled
[    9.170000] rt3xxx-usbphy usbphy.3: UTMI 16bit 30MHz
[    9.180000] ehci-platform 101c0000.ehci: EHCI Host Controller
[    9.190000] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    9.200000] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    9.240000] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    9.250000] hub 1-0:1.0: USB hub found
[    9.260000] hub 1-0:1.0: 1 port detected
[    9.490000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    9.500000] ohci-platform 101c1000.ohci: Generic Platform OHCI Controller
[    9.520000] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    9.530000] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    9.610000] hub 2-0:1.0: USB hub found
[    9.620000] hub 2-0:1.0: 1 port detected
[    9.630000] leds-gpio gpio-leds.5: pins are not configured from the driver
procd: - preinit -
[   45.540000] rt305x-esw 10110000.esw: link changed 0x00

Vonger
 
Posts: 634
Joined: Sun Oct 19, 2014 6:00 am

Re: vocore +Dock(v2) hangs at procd: - preinit -

Thu Mar 08, 2018 2:14 pm

Try to flash new firmware when start up VoCore2(press zero)

Return to VoCore & VoCore+dock

Who is online

Users browsing this forum: No registered users and 7 guests