Kernel Version

dadiy
 
Posts: 6
Joined: Sat Nov 15, 2014 6:04 pm

Kernel Version

Sat Nov 15, 2014 6:06 pm

Hi,

I got my vocore delivered in the UK on Friday and it works great. Although when I tried to use opkg to install some packages Ive found that its running an older kernel.

Is there any easy way to update this to use the openwrt kernel 3.14.18-1 as this appears to be a dependancy for most packages, I wanted to install the bluetooth bluez package but that also requires this version.

Pyrofer
 
Posts: 61
Joined: Tue Oct 21, 2014 11:35 am

Re: Kernel Version

Sun Nov 16, 2014 10:46 am

I downloaded the openwrt build environment and selected the VoCore as target. You can build it all yourself easily then.
This is also the easiest way to cross-compile your own apps.

dadiy
 
Posts: 6
Joined: Sat Nov 15, 2014 6:04 pm

Re: Kernel Version

Mon Nov 17, 2014 10:33 am

It would be really nice if someone could post a pre compiled latest software for vocore and instructions how to apply it?

dadiy
 
Posts: 6
Joined: Sat Nov 15, 2014 6:04 pm

Re: Kernel Version

Mon Nov 17, 2014 11:34 am

I grabbed the latest version from the OpenWRT site but it turns out to be 3.10.49 which is a real shame.

dadiy
 
Posts: 6
Joined: Sat Nov 15, 2014 6:04 pm

Re: Kernel Version

Wed Nov 19, 2014 10:10 am

Just following up on my own post.

For those too lazy to build their own openwrt package the latest bleeding edge version can be downloaded from the openwrt site here -

http://downloads.openwrt.org/snapshots/trunk/ramips/

Just look for the file named openwrt-ramips-rt305x-vocore-squashfs-sysupgrade.bin

I used Luci to upgrade, but note that the latest versions do not install Luci by default and that this needs to be added with opkg.

I also read that packages for these builds are rebuilt daily so if you load the bleeding edge and then try to add a package some time later they might be out of sync and the base OS would need to be reinstalled. At least until this branch moves to stable.

darksoul
 
Posts: 45
Joined: Fri Nov 14, 2014 2:29 am

Re: Kernel Version

Fri Nov 21, 2014 5:53 am

dadiy wrote:Just following up on my own post.

For those too lazy to build their own openwrt package the latest bleeding edge version can be downloaded from the openwrt site here -

http://downloads.openwrt.org/snapshots/trunk/ramips/

Just look for the file named openwrt-ramips-rt305x-vocore-squashfs-sysupgrade.bin

I used Luci to upgrade, but note that the latest versions do not install Luci by default and that this needs to be added with opkg.

I also read that packages for these builds are rebuilt daily so if you load the bleeding edge and then try to add a package some time later they might be out of sync and the base OS would need to be reinstalled. At least until this branch moves to stable.



The Firmware that you suggested is not stable, vocore can freeze in the middle of something, or just reboot.
Did tests for 2 hours, 3 times did manual reset by removing power, 2 times self reboot.

undead
 
Posts: 2
Joined: Thu Nov 20, 2014 7:19 am

Re: Kernel Version

Fri Nov 21, 2014 10:19 am

I found vocore stable image exists in http://downloads.openwrt.org/barrier_br ... ps/rt305x/
Is anybody know, is image trully stable or have some bugs?

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: Bing [Bot] and 3 guests