Busybox Upgrade Failed, now fails to boot, can't Uboot.

Capn
 
Posts: 2
Joined: Fri Sep 18, 2015 6:57 am

Busybox Upgrade Failed, now fails to boot, can't Uboot.

Fri Sep 18, 2015 7:14 am

Hi all,

I have a problem and have not been able to find a solution, I hope someone here can help me.

Context: Connected to VoCore via ethernet cable using PuTTY.

I was upgrading Busybox using 'opkg upgrade busybox' and it failed towards the end giving the error "busybox.postinst returned 255". I re-tried installation, but it went straight to that error again. I then tried to navigate to the busybox package but the command 'ls' was not working "-ash: ls: not found". The 'cd' command was still working, so I figured I would simply reboot the VoCore and try again. That's when the real problem started. I couldn't get back in through PuTTY via wifi or ethernet, and so I pulled out the USB-TTL adapter (thanks for including it!!) and connected via PuTTY serial. I found that there were a lot of errors as the VoCore was trying to boot up but was unsuccessful. At first it said "/bin/askfirst: Please press enter to activate this console". So I did. It then asked me again, and again, no matter how many times I pressed enter. So I rebooted again. This time it did not ask me to press enter, instead stopping at one of many errors and not allowing me to input any values (it gave many CRC errors). I then figured I should re-install OpenWRT, so following the tutorials (make menuconfig etc.) I recompiled OpenWRT but to install it I needed to access uboot, which I have found to be impossible. I connected my VoCore via USB-TTL adapter to my PC, and tried to press 'x' as I supplied the VoCore with power, but it was no use- the serial connection will no longer allow me to input any values.

What should I do now? I have tried everything I can think of with what I have...
To summarize:
- VoCore won't fully boot to OpenWrt after failed busybox update
-Can only access via serial (USB-TTL)
-Appears to be read-only (can't enter data, so no way of pressing 'x' to enter uboot settings)
-Many CRC errors

I would be very grateful for some assistance on this issue!
Thanks in advance!

Vonger
 
Posts: 768
Joined: Sun Oct 19, 2014 6:00 am

Re: Busybox Upgrade Failed, now fails to boot, can't Uboot.

Tue Sep 22, 2015 10:39 am

Hi,
You can use uboot to redo flash the firmware, please check http://vocore.io/wiki/index/id:14, section 2, UBoot-Kermit: connect to uartlite first.
It will transfer data through UART, very slow, takes about 10minutes. Or you can use tftpd send data to it, that will be faster.

noblepepper
 
Posts: 240
Joined: Sat Nov 29, 2014 3:22 pm

Re: Busybox Upgrade Failed, now fails to boot, can't Uboot.

Fri Sep 25, 2015 4:33 pm

I had a cold solder joint on one of the VoCore's serial pins that would not let me get into uboot with x but everything worked normally once uboot started the linux load process. Double check your connections.

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: No registered users and 2 guests