Pico-Kubik, a tiny quadruped robot

deshipu
 
Posts: 21
Joined: Wed Nov 19, 2014 5:10 pm

Pico-Kubik, a tiny quadruped robot

Wed Nov 19, 2014 11:47 pm

Hello,

I'm building a very small spider-like robot, and VoCore seems to be the perfect choice for its brains. I didn't want to muck about with PWM drivers, so I decided to make a simple servo controller out of an Arduino Pro Mini, and I plan to communicate with it from VoCore trough TTL, from a program running on Micropython.

You can follow that project here: http://hackaday.io/project/3301-pico-ku ... uped-robot

However, I can't seem to be able to get /dev/ttyS1 to work. Do I need to change something in configuration somewhere to make the other UART (not the one on which the console runs) available?

deshipu
 
Posts: 21
Joined: Wed Nov 19, 2014 5:10 pm

Re: Pico-Kubik, a tiny quadruped robot

Thu Nov 20, 2014 3:03 pm

Ok, I found http://vonger.cn/?p=1409 telling me how to enable the second UART. Turns out /dev/ttyS1 is used internally and is not the second UART.

deshipu
 
Posts: 21
Joined: Wed Nov 19, 2014 5:10 pm

Re: Pico-Kubik, a tiny quadruped robot

Mon Nov 24, 2014 11:33 pm

I have all parts of the robot connected and working, and some simple example programs prove, that it works. Now I need to work on real software for it, and maybe a better chassis.

Image

By the way, I noticed that sometimes (not sure why, weaker battery maybe?) VoCore boots with less memory available than usually:

Code: Select all
root@OpenWrt:~# free
             total         used         free       shared      buffers
Mem:         13312        12712          600            0          804
-/+ buffers:              11908         1404
Swap:            0            0            0


Any idea why that may be?

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: No registered users and 4 guests