How to connect vocore2 to my fios wifi?[SOLVED]

cory
 
Posts: 35
Joined: Sun Dec 18, 2016 1:00 am

How to connect vocore2 to my fios wifi?[SOLVED]

Mon Dec 26, 2016 12:43 am

I went thru the AP+STA Help Please thread, repeat all the steps including 'horrible hacking ' step but it seems I still need to do something more. Here are what I have

Code: Select all
Code: Select all
root@OpenWrt:/# cat /etc/rc.local
uci set wireless.sta.disabled=0
uci commit
/etc/init.d/network restart
sleep 10
uci set wireless.sta.disabled=1
uci commit
# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

exit 0
root@OpenWrt:/#

root@OpenWrt:/# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'CN'
        option hwmode '11ng'
        option htmode 'HT40'
        option channel 'auto'
        option disabled '0'

config wifi-iface 'ap'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option ssid 'VoCore2'
        option encryption 'none'

config wifi-iface 'sta'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ifname 'apcli0'
        option led 'mediatek:orange:wifi'
        option ssid 'FiOS-XXXX'
        option key 'xxxxxxxxxxxxxx'
        option encryption 'WPA2-PSK'
        option disabled '1'

root@OpenWrt:/#


root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd45:0149:ac86::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option macaddr 'b8:d8:12:67:05:cd'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option force_link '1'
        option macaddr 'b8:d8:12:67:05:ce'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'

root@OpenWrt:/#
root@OpenWrt:/#  iwinfo
apcli0    ESSID: "FiOS-XXXX"
          Access Point: 48:5D:36:48:E1:FA
          Mode: Client  Channel: 1 (2.412 GHz)
          Tx-Power: 17 dBm  Link Quality: unknown/100
          Signal: unknown  Noise: unknown
          Bit Rate: 150.0 MBit/s
          Encryption: unknown
          Type: wext  HW Mode(s): 802.11bg
          Hardware: unknown [Generic WEXT]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: no  PHY name: apcli0

apcli1    ESSID: unknown
          Access Point: 00:00:00:00:00:00
          Mode: Client  Channel: 1 (2.412 GHz)
          Tx-Power: 17 dBm  Link Quality: unknown/100
          Signal: unknown  Noise: unknown
          Bit Rate: 150.0 MBit/s
          Encryption: unknown
          Type: wext  HW Mode(s): 802.11bg
          Hardware: unknown [Generic WEXT]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: no  PHY name: apcli1

ra0       ESSID: "VoCore2"
          Access Point: B8:D8:12:67:05:CD
          Mode: Client  Channel: 1 (2.412 GHz)
          Tx-Power: 17 dBm  Link Quality: 10/100
          Signal: -256 dBm  Noise: -79 dBm
          Bit Rate: 150.0 MBit/s
          Encryption: unknown
          Type: wext  HW Mode(s): 802.11bg
          Hardware: unknown [Generic WEXT]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: no  PHY name: ra0

root@OpenWrt:/#
root@OpenWrt:/#  ifconfig |grep -C5 apcli
apcli0    Link encap:Ethernet  HWaddr BA:D8:12:07:05:CD
          inet6 addr: fe80::b8d8:12ff:fe07:5cd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
root@OpenWrt:/#
root@OpenWrt:/# ping -c3 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network is unreachable
root@OpenWrt:/#


I think I am still missing a line in ifconfig |grep -C5 apcli section
Last edited by cory on Thu Dec 29, 2016 2:13 am, edited 1 time in total.

Vonger
 
Posts: 896
Joined: Sun Oct 19, 2014 6:00 am

Re: How to connect vocore2 to my fios wifi?

Mon Dec 26, 2016 8:13 am

apcli0 ESSID: "FiOS-XXXX"
Access Point: 48:5D:36:48:E1:FA
Mode: Client Channel: 1 (2.412 GHz)
Tx-Power: 17 dBm Link Quality: unknown/100
Signal: unknown Noise: unknown
Bit Rate: 150.0 MBit/s
Encryption: unknown
Type: wext HW Mode(s): 802.11bg
Hardware: unknown [Generic WEXT]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: no PHY name: apcli0

this shows it is already connected to your home ap.
Do you setup your firewall? You still need to setup it by the instruction.

cory
 
Posts: 35
Joined: Sun Dec 18, 2016 1:00 am

Re: How to connect vocore2 to my fios wifi?

Mon Dec 26, 2016 4:24 pm

my firewall is identical with firewall post by the guy asking for help from AP+STA thread.

Code: Select all
root@OpenWrt:/# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fe80::/10
        option src_port         547
        option dest_ip          fe80::/10
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

# allow IPsec/ESP and ISAKMP passthrough
config rule
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
root@OpenWrt:/#

cory
 
Posts: 35
Joined: Sun Dec 18, 2016 1:00 am

Re: How to connect vocore2 to my fios wifi?

Mon Dec 26, 2016 8:13 pm

change firewall
Code: Select all
root@OpenWrt:/# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config wifi-iface
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fe80::/10
        option src_port         547
        option dest_ip          fe80::/10
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

# allow IPsec/ESP and ISAKMP passthrough
config rule
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option s


reboot, still can't ping to google.com

cory
 
Posts: 35
Joined: Sun Dec 18, 2016 1:00 am

Re: How to connect vocore2 to my fios wifi?

Thu Dec 29, 2016 1:17 am

Finally I can connect to Fios WiFI :mrgreen: I think the trick is using uci command first before using vim to modify the command result. I was using vim to type in some of the lines and they didn't 'take', didn't do anything I guess. I also install the firmware he posted http://vocore.io/v2u.html that may help too.

Code: Select all


BusyBox v1.23.2 (2016-09-03 09:56:08 CST) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Chaos Calmer, r49378)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# cat etc/config/wireless

config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'CN'
        option hwmode '11ng'
        option channel 'auto'
        option disabled '0'

config wifi-iface 'ap'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option ssid 'VoCore2'
        option encryption 'psk'
        option key 'xxxxxxx'

config wifi-iface 'sta'
        option device 'radio0'
        option network 'wwan'
        option ifname 'apcli0'
        option led 'mediatek:orange:wifi'
        option ssid 'FiOS-XXXX'
        option key 'xxxxxxxxxxxx'
        option encryption 'psk2'
        option mode 'sta'
        option identity 'OpenWrt'
        option disabled '1'



root@OpenWrt:/# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 wwan'

<snip>

noblepepper
 
Posts: 240
Joined: Sat Nov 29, 2014 3:22 pm

Re: How to connect vocore2 to my fios wifi?[SOLVED]

Thu Dec 29, 2016 11:05 am

Using uci vs editting the files shouldn't make any difference.

I have had much better luck with the 20161224 image, this is my choice for what made the difference.

cory
 
Posts: 35
Joined: Sun Dec 18, 2016 1:00 am

Re: How to connect vocore2 to my fios wifi?[SOLVED]

Thu Dec 29, 2016 3:31 pm

re: uci vs editing
after connecting to wifi I want to secure vocore2 so I used vim to add 2 lines , reboot
Code: Select all
config wifi-iface 'ap'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option ssid 'VoCore2'
        option encryption 'psk'   <====  added thru vim
        option key 'xxxxxxx'      <====  added thru vim


then I see vocore2 asking for password but after I entered the same password it just keep on asking again.
I google some more then issue uci command to enter them and use uci wireless commit instead of just uci commit.
Maybe it didn't make any diff. but it doesn't hurt to try if wim didn't work.

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 44 guests