Setup AP + STA Mode

herci
 
Posts: 27
Joined: Thu Dec 29, 2016 2:32 pm

Setup AP + STA Mode

Sun Jan 08, 2017 3:35 pm

I tried to setup AP and STA, assuming this means if I'm connected with my vocore for airplay I can still surf on the internet because vocore is a sort of wifi extending point. Let's hope I got this right.

I did the following from the tutorial

I opened Putty

then I copy pasted in parts the following:

uci set wireless.sta.ssid=[the name of my network]

uci set wireless.sta.key=[password of my wifi network]

uci set wireless.sta.network=wwan

uci set wireless.sta.disabled=0

uci commit

/etc/init.d/network restart




then this:

sleep 10

uci set wireless.sta.disabled=1

uci commit

then;

uci delete network.wwan

uci set network.wwan=interface

uci set network.wwan.proto=dhcp

uci commit

finally:

uci del_list firewall.@zone[1].network=wwan

uci add_list firewall.@zone[1].network=wwan

uci set firewall.@zone[1].input=ACCEPT

uci set firewall.@zone[1].output=ACCEPT

uci set firewall.@zone[1].forward=ACCEPT

uci set firewall.@zone[1].masq=1

uci set firewall.@zone[1].mtu_fix=1

uci commit



I tried it with my wifi extender (it is WPA2). I also tried it with my original router not sure if that one is wpa or wpa 2
But it doesn't seem to work.

kosmonaut pirx
 
Posts: 17
Joined: Mon Jan 02, 2017 11:35 pm

Re: Setup AP + STA Mode

Sun Jan 08, 2017 4:39 pm

hello,
you should check what's wrong in detail.

As you have ssh access already, I'd recommend to have a separate session running the command
Code: Select all
logread -f

always at hand. So you see what's happening.

In an additional ssh session try your setup. The logread at the other session should show something like this
kern.info ap_client: Found network, trying to associate (essid: ... etc pp
daemon.notice netifd: wan (1483): Sending discover...
kern.info ap_client: apcli0 is associated
daemon.notice netifd: Network device 'apcli0' link is up
daemon.notice netifd: Interface 'wifi_sta' is enabled
daemon.notice netifd: Interface 'wifi_sta' has link connectivity
daemon.notice netifd: Interface 'wifi_sta' is setting up now

(my network is called 'wifi_sta', the tutorial uses 'wwan')

So first check if you're associated with yourr AP at least.
If not, you don't need to check any further, nothing will work.
Otherwise, you're associated with the AP, but for some reason it denies you. Check encryption required by AP, check the key and/or use a simple example key if possible (for this, you changed the key at the AP as well, don't you?)

Check with a reboot (for windows users) or a simple 'wifi' command at ssh/putty console.
Hth, regards

herci
 
Posts: 27
Joined: Thu Dec 29, 2016 2:32 pm

Re: Setup AP + STA Mode

Sun Jan 08, 2017 8:54 pm

not sure how to: try my setup
I tried all the command again with logread on
then I started again with the usb cable and typed wifi

this is what I got

root@OpenWrt:~# logread -f
Sat Dec 24 14:10:24 2016 authpriv.warn dropbear[1354]: Login attempt for nonexis tent user from 192.168.1.146:49279
Sat Dec 24 14:10:28 2016 authpriv.warn dropbear[1354]: Login attempt for nonexis tent user from 192.168.1.146:49279
Sat Dec 24 14:10:47 2016 authpriv.warn dropbear[1354]: Login attempt for nonexistent user from 192.168.1.146:49279
Sat Dec 24 14:10:58 2016 authpriv.info dropbear[1354]: Exit before auth: Exited normally
Sat Dec 24 14:11:00 2016 daemon.info dnsmasq-dhcp[1291]: DHCPINFORM(br-lan) 192.168.1.146 10:0b:a9:37:ca:30
Sat Dec 24 14:11:00 2016 daemon.info dnsmasq-dhcp[1291]: DHCPACK(br-lan) 192.168.1.146 10:0b:a9:37:ca:30 MININT-VT9MA5R
Sat Dec 24 14:11:21 2016 authpriv.info dropbear[1361]: Child connection from 192.168.1.146:49280
Sat Dec 24 14:11:28 2016 authpriv.notice dropbear[1361]: Password auth succeeded for 'root' from 192.168.1.146:49280
Sat Dec 24 14:13:57 2016 kern.warn kernel: [ 300.720000] /openwrt/CC/build_dir/ target-mipsel_24kec+dsp_uClibc-0.9.33.2/linux-ramips_mt7688/mt7628-4.0.1.3/mt_wi fi_ap/../mt_wifi/embedded/os/linux/ap_ioctl.c:rt28xx_ap_ioctl[265]
Sat Dec 24 14:13:57 2016 kern.warn kernel: [ 300.990000] /openwrt/CC/build_dir/ target-mipsel_24kec+dsp_uClibc-0.9.33.2/linux-ramips_mt7688/mt7628-4.0.1.3/mt_wi fi_ap/../mt_wifi/embedded/os/linux/ap_ioctl.c:rt28xx_ap_ioctl[265]
Sat Dec 24 14:13:57 2016 kern.warn kernel: [ 301.270000] /openwrt/CC/build_dir/ target-mipsel_24kec+dsp_uClibc-0.9.33.2/linux-ramips_mt7688/mt7628-4.0.1.3/mt_wi fi_ap/../mt_wifi/embedded/os/linux/ap_ioctl.c:rt28xx_ap_ioctl[265]
Sat Dec 24 14:15:45 2016 daemon.info dnsmasq-dhcp[1291]: DHCPINFORM(br-lan) 192. 168.1.146 10:0b:a9:37:ca:30
Sat Dec 24 14:15:45 2016 daemon.info dnsmasq-dhcp[1291]: DHCPACK(br-lan) 192.168 .1.146 10:0b:a9:37:ca:30 MININT-VT9MA5R
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'lan' is now down
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Registering new address record for fe80::bad8:12ff:fe67:13e0 on br-lan.*.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Withdrawing address rec ord for 192.168.1.1 on br-lan.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Leaving mDNS multicast group on interface br-lan.IPv4 with address 192.168.1.1.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Interface br-lan.IPv4 n o longer relevant for mDNS.
Sat Dec 24 14:22:31 2016 kern.info kernel: [ 815.020000] br-lan: port 2(ra0) en tered disabled state
Sat Dec 24 14:22:31 2016 kern.info kernel: [ 815.030000] br-lan: port 1(eth0.1) entered disabled state
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Interface br-lan.IPv6 n o longer relevant for mDNS.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Leaving mDNS multicast group on interface br-lan.IPv6 with address fd1c:5a88:47dd::1.
Sat Dec 24 14:22:31 2016 kern.info kernel: [ 815.050000] device eth0.1 left pro miscuous mode
Sat Dec 24 14:22:31 2016 kern.info kernel: [ 815.050000] br-lan: port 1(eth0.1) entered disabled state
Sat Dec 24 14:22:31 2016 kern.info kernel: [ 815.060000] IPv6: ADDRCONF(NETDEV_ UP): eth0.1: link is not ready
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Withdrawing address rec ord for fd1c:5a88:47dd::1 on br-lan.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Withdrawing address rec ord for fe80::bad8:12ff:fe67:13e0 on br-lan.
Sat Dec 24 14:22:31 2016 kern.info kernel: [ 815.090000] device ra0 left promis cuous mode
Sat Dec 24 14:22:31 2016 kern.info kernel: [ 815.090000] br-lan: port 2(ra0) en tered disabled state
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'lan' is disabled
Sat Dec 24 14:22:31 2016 daemon.notice netifd: VLAN 'eth0.1' link is down
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Bridge 'br-lan' link is down
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'lan' has link connecti vity loss
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'loopback' is now down
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'loopback' is disabled
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Network device 'lo' link is down
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'loopback' has link con nectivity loss
Sat Dec 24 14:22:31 2016 daemon.info dnsmasq[1291]: read /etc/hosts - 1 addresse s
Sat Dec 24 14:22:31 2016 daemon.info dnsmasq[1291]: read /tmp/hosts/odhcpd - 0 a ddresses
Sat Dec 24 14:22:31 2016 daemon.info dnsmasq[1291]: read /tmp/hosts/dhcp - 1 add resses
Sat Dec 24 14:22:31 2016 daemon.info dnsmasq-dhcp[1291]: read /etc/ethers - 0 ad dresses
Sat Dec 24 14:22:31 2016 daemon.notice netifd: wan (1043): Received SIGTERM
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'wan' is now down
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'wan6' is now down
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Interface eth0.2.IPv6 n o longer relevant for mDNS.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Leaving mDNS multicast group on interface eth0.2.IPv6 with address fe80::bad8:12ff:fe67:13e1.
Sat Dec 24 14:22:31 2016 kern.info kernel: [ 815.360000] device eth0 left promi scuous mode
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'wan' is disabled
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'wan6' is disabled
Sat Dec 24 14:22:31 2016 daemon.notice netifd: VLAN 'eth0.2' link is down
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'wan' has link connecti vity loss
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Interface 'wan6' has link connect ivity loss
Sat Dec 24 14:22:31 2016 daemon.notice netifd: Network device 'eth0' link is dow n
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Withdrawing address rec ord for fe80::bad8:12ff:fe67:13e1 on eth0.2.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Interface eth0.IPv6 no longer relevant for mDNS.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Leaving mDNS multicast group on interface eth0.IPv6 with address fe80::3c30:52ff:fe26:3562.
Sat Dec 24 14:22:31 2016 daemon.info avahi-daemon[1157]: Withdrawing address rec ord for fe80::3c30:52ff:fe26:3562 on eth0.
Sat Dec 24 14:22:33 2016 user.notice root: drv_ralink_cleanup
Sat Dec 24 14:22:33 2016 kern.info kernel: [ 817.130000] device eth0.1 entered promiscuous mode
Sat Dec 24 14:22:33 2016 kern.info kernel: [ 817.140000] device eth0 entered pr omiscuous mode
Sat Dec 24 14:22:33 2016 kern.info kernel: [ 817.160000] br-lan: port 1(eth0.1) entered forwarding state
Sat Dec 24 14:22:33 2016 kern.info kernel: [ 817.160000] br-lan: port 1(eth0.1) entered forwarding state
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'lan' is enabled
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'lan' is setting up now
Sat Dec 24 14:22:33 2016 daemon.info avahi-daemon[1157]: Joining mDNS multicast group on interface br-lan.IPv4 with address 192.168.1.1.
Sat Dec 24 14:22:33 2016 daemon.info avahi-daemon[1157]: New relevant interface br-lan.IPv4 for mDNS.
Sat Dec 24 14:22:33 2016 daemon.info avahi-daemon[1157]: Registering new address record for 192.168.1.1 on br-lan.IPv4.
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'lan' is now up
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'loopback' is enabled
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'loopback' is setting u p now
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'loopback' is now up
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'wan' is enabled
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'wan6' is enabled
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Bridge 'br-lan' link is up
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'lan' has link connecti vity
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Network device 'eth0' link is up
Sat Dec 24 14:22:33 2016 daemon.notice netifd: VLAN 'eth0.1' link is up
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Network device 'lo' link is up
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'loopback' has link con nectivity
Sat Dec 24 14:22:33 2016 daemon.notice netifd: VLAN 'eth0.2' link is up
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'wan' has link connecti vity
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'wan6' has link connect ivity
Sat Dec 24 14:22:33 2016 daemon.notice netifd: Interface 'wan6' is setting up no w
Sat Dec 24 14:22:33 2016 daemon.notice netifd: wan (1543): udhcpc (v1.23.2) star ted
Sat Dec 24 14:22:34 2016 daemon.notice netifd: radio0 (1522): Interface doesn't accept private ioctl...
Sat Dec 24 14:22:34 2016 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Sat Dec 24 14:22:34 2016 daemon.notice netifd: radio0 (1522): set (8BE2): Invali d argument
Sat Dec 24 14:22:34 2016 daemon.notice netifd: wan (1543): Sending discover...
Sat Dec 24 14:22:34 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:22:34 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:22:34 2016 daemon.info avahi-daemon[1157]: Joining mDNS multicast group on interface br-lan.IPv6 with address fd1c:5a88:47dd::1.
Sat Dec 24 14:22:34 2016 daemon.info avahi-daemon[1157]: New relevant interface br-lan.IPv6 for mDNS.
Sat Dec 24 14:22:34 2016 daemon.info avahi-daemon[1157]: Registering new address record for fd1c:5a88:47dd::1 on br-lan.*.
Sat Dec 24 14:22:34 2016 daemon.info avahi-daemon[1157]: Joining mDNS multicast group on interface eth0.2.IPv6 with address fe80::bad8:12ff:fe67:13e1.
Sat Dec 24 14:22:34 2016 daemon.info avahi-daemon[1157]: New relevant interface eth0.2.IPv6 for mDNS.
Sat Dec 24 14:22:34 2016 daemon.info avahi-daemon[1157]: Registering new address record for fe80::bad8:12ff:fe67:13e1 on eth0.2.*.
Sat Dec 24 14:22:35 2016 daemon.info avahi-daemon[1157]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::3c30:52ff:fe26:3562.
Sat Dec 24 14:22:35 2016 daemon.info avahi-daemon[1157]: New relevant interface eth0.IPv6 for mDNS.
Sat Dec 24 14:22:35 2016 daemon.info avahi-daemon[1157]: Registering new address record for fe80::3c30:52ff:fe26:3562 on eth0.*.
Sat Dec 24 14:22:35 2016 kern.info kernel: [ 819.160000] br-lan: port 1(eth0.1) entered forwarding state
Sat Dec 24 14:22:35 2016 daemon.notice netifd: Network device 'ra0' link is up
Sat Dec 24 14:22:35 2016 kern.info kernel: [ 819.230000] device ra0 entered pro miscuous mode
Sat Dec 24 14:22:35 2016 kern.info kernel: [ 819.240000] br-lan: port 2(ra0) en tered forwarding state
Sat Dec 24 14:22:35 2016 kern.info kernel: [ 819.240000] br-lan: port 2(ra0) en tered forwarding state
Sat Dec 24 14:22:35 2016 daemon.notice netifd: Interface 'wwan' is enabled
Sat Dec 24 14:22:36 2016 daemon.warn odhcpd[945]: DHCPV6 CONFIRM IA_NA from 0001 00011f69939df0def1bc2580 on br-lan: not on-link
Sat Dec 24 14:22:36 2016 daemon.info dnsmasq-dhcp[1291]: DHCPREQUEST(br-lan) 192 .168.1.146 10:0b:a9:37:ca:30
Sat Dec 24 14:22:36 2016 daemon.info dnsmasq-dhcp[1291]: DHCPACK(br-lan) 192.168 .1.146 10:0b:a9:37:ca:30 MININT-VT9MA5R
Sat Dec 24 14:22:36 2016 daemon.warn odhcpd[945]: DHCPV6 SOLICIT IA_NA from 0001 00011f69939df0def1bc2580 on br-lan: ok fd1c:5a88:47dd::753/128
Sat Dec 24 14:22:37 2016 daemon.notice netifd: wan (1543): Sending discover...
Sat Dec 24 14:22:37 2016 kern.info kernel: [ 821.240000] br-lan: port 2(ra0) en tered forwarding state
Sat Dec 24 14:22:37 2016 daemon.warn odhcpd[945]: DHCPV6 REQUEST IA_NA from 0001 00011f69939df0def1bc2580 on br-lan: ok fd1c:5a88:47dd::753/128
Sat Dec 24 14:22:37 2016 daemon.info dnsmasq[1291]: read /etc/hosts - 1 addresse s
Sat Dec 24 14:22:37 2016 daemon.info dnsmasq[1291]: read /tmp/hosts/odhcpd - 1 a ddresses
Sat Dec 24 14:22:37 2016 daemon.info dnsmasq[1291]: read /tmp/hosts/dhcp - 1 add resses
Sat Dec 24 14:22:37 2016 daemon.info dnsmasq-dhcp[1291]: read /etc/ethers - 0 ad dresses
Sat Dec 24 14:22:37 2016 daemon.info dnsmasq-dhcp[1291]: DHCPINFORM(br-lan) 192. 168.1.146 10:0b:a9:37:ca:30
Sat Dec 24 14:22:37 2016 daemon.info dnsmasq-dhcp[1291]: DHCPACK(br-lan) 192.168 .1.146 10:0b:a9:37:ca:30 MININT-VT9MA5R
Sat Dec 24 14:22:39 2016 kern.info ap_client: No results
Sat Dec 24 14:22:39 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:22:40 2016 daemon.notice netifd: wan (1543): Sending discover...
Sat Dec 24 14:22:49 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:22:49 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:22:54 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2P SK
Sat Dec 24 14:22:54 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:23:04 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:23:04 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:23:09 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:23:09 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:23:19 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:23:19 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:23:24 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:23:24 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:23:34 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:23:34 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:23:39 2016 kern.info ap_client: No results
Sat Dec 24 14:23:39 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:23:49 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:23:49 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:23:54 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:23:54 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:24:04 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:24:04 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:24:09 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:24:09 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:24:19 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:24:19 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:24:24 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:24:24 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:24:34 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:24:34 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:24:39 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:24:39 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:24:49 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:24:49 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:24:54 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:24:54 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:25:04 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:25:04 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:25:09 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:25:09 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:25:19 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:25:19 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:25:24 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:25:24 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:25:34 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:25:34 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:25:39 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:25:39 2016 kern.info ap_client: Found network - 6 telenet-E04E1 dc:53:7c:9e:04:e6 WPA1PSKWPA2PSK
Sat Dec 24 14:25:39 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:25:45 2016 daemon.info dnsmasq-dhcp[1291]: DHCPINFORM(br-lan) 192.168.1.146 10:0b:a9:37:ca:30
Sat Dec 24 14:25:45 2016 daemon.info dnsmasq-dhcp[1291]: DHCPACK(br-lan) 192.168.1.146 10:0b:a9:37:ca:30 MININT-VT9MA5R
Sat Dec 24 14:25:49 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:25:49 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:25:54 2016 kern.info ap_client: No results
Sat Dec 24 14:25:54 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:26:04 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:26:04 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:26:09 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:26:09 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:26:19 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:26:19 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:26:24 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:26:24 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:26:34 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:26:34 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:26:39 2016 kern.info ap_client: No results
Sat Dec 24 14:26:39 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:26:49 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:26:49 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:26:54 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:26:54 2016 kern.info ap_client: Found network - 6 telenet-E04E1 dc:53:7c:9e:04:e6 WPA1PSKWPA2PSK
Sat Dec 24 14:26:54 2016 kern.info ap_client: Found network - 11 WiFi-2.4-AA26 00:37:b7:74:aa:2c WPA2PSK
Sat Dec 24 14:26:54 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:27:04 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:27:04 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:27:09 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:27:09 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:27:19 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:27:19 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:27:24 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:27:24 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:27:34 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:27:34 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:27:39 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:27:39 2016 kern.info ap_client: Found network - 11 WiFi-2.4-AA26 00:37:b7:74:aa:2c WPA2PSK
Sat Dec 24 14:27:39 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:27:49 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:27:49 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:27:54 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:27:54 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:28:04 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:28:04 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:28:09 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:28:09 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:28:19 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:28:19 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:28:24 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:28:24 2016 kern.info ap_client: Found network - 11 WiFi-2.4-AA26 00:37:b7:74:aa:2c WPA2PSK
Sat Dec 24 14:28:24 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:28:34 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:28:34 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:28:39 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:28:39 2016 kern.info ap_client: Found network - 11 WiFi-2.4-AA26 00:37:b7:74:aa:2c WPA2PSK
Sat Dec 24 14:28:39 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:28:49 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:28:49 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:28:54 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:28:54 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:29:04 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:29:04 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:29:09 2016 kern.info ap_client: Found network - 11 WiFi-2.4-AA26 00:37:b7:74:aa:2c WPA2PSK
Sat Dec 24 14:29:09 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:29:19 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:29:19 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:29:24 2016 kern.info ap_client: Found network - 1 telenet-apn-D4F49 ac:f1:df:d2:98:f6 WPA1PSKWPA2PSK
Sat Dec 24 14:29:24 2016 kern.info ap_client: No signal found to connect to
Sat Dec 24 14:29:34 2016 kern.info ap_client: apcli0 is not associated
Sat Dec 24 14:29:34 2016 kern.info ap_client: Scanning for networks...
Sat Dec 24 14:29:35 2016 daemon.notice netifd: Interface 'wwan' is disabled




and

root@OpenWrt:/# wifi
root@OpenWrt:/# [ 1310.310000] br-lan: port 2(ra0) entered disabled state
[ 1310.330000] device ra0 left promiscuous mode
[ 1310.330000] br-lan: port 2(ra0) entered disabled state
[ 1310.690000] efuse_probe: efuse = 10000002
[ 1310.860000] tssi_0_target_pwr_g_band = 35
[ 1310.860000] tssi_1_target_pwr_g_band = 35
[ 1316.110000] <==== rt28xx_init, Status=0
[ 1316.240000] device ra0 entered promiscuous mode
[ 1316.240000] br-lan: port 2(ra0) entered forwarding state
[ 1316.250000] br-lan: port 2(ra0) entered forwarding state
[ 1318.250000] br-lan: port 2(ra0) entered forwarding state




my network is telenet-apn

kosmonaut pirx
 
Posts: 17
Joined: Mon Jan 02, 2017 11:35 pm

Re: Setup AP + STA Mode

Sun Jan 08, 2017 9:18 pm

for "try your setup" I just use "wifi" command

according to the log, you've at max three wifi's in range:
telenet-apn-D4F49
telenet-E04E1
WiFi-2.4-AA26

but according to this
Sat Dec 24 14:29:24 2016 kern.info ap_client: No signal found to connect to

you don't want to connect to any of them.
This message I receive in case I use an unknown ssid.

Therefore, please check the ssid given, either in comamnd used
uci set wireless.sta.ssid=
of in
/etc/config/wireless.

name have to match.

herci
 
Posts: 27
Joined: Thu Dec 29, 2016 2:32 pm

Re: Setup AP + STA Mode

Mon Jan 09, 2017 8:43 pm

I did all the commands from the first post again and I just copied the name of my wifi, to assure I made no mistakes in the following line
uci set wireless.sta.ssid=[telenet-apn-D4F49]

you talk about a etc/config/wireless command, but there isn't a command like this in the tutorial, did I forget something?

Then I connected through serial again, because when I ssh and type wifi I disconnect.

And typed in serial connection: 'wifi' and I get this:


root@OpenWrt:/# wifi
root@OpenWrt:/# [ 538.620000] br-lan: port 2(ra0) entered disabled state
[ 538.660000] device ra0 left promiscuous mode
[ 538.660000] br-lan: port 2(ra0) entered disabled state
[ 539.020000] efuse_probe: efuse = 10000002
[ 539.180000] tssi_0_target_pwr_g_band = 35
[ 539.190000] tssi_1_target_pwr_g_band = 35
[ 544.450000] <==== rt28xx_init, Status=0
[ 544.580000] device ra0 entered promiscuous mode
[ 544.580000] br-lan: port 2(ra0) entered forwarding state
[ 544.590000] br-lan: port 2(ra0) entered forwarding state
[ 546.590000] br-lan: port 2(ra0) entered forwarding state

I also did a reboot and got this:

3: System Boot system code via Flash.
## Booting image at bc050000 ...
Image Name: MIPS OpenWrt Linux-3.18.29
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 1146194 Bytes = 1.1 MB
Load Address: 80000000
Entry Point: 80000000
Verifying Checksum ... OK
Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80000000) ...
## Giving linux memsize in MB, 128

Starting kernel ...

[ 0.000000] Linux version 3.18.29 (vocore@ubuntu) (gcc version 4.8.3 (OpenWrt /Linaro GCC 4.8-2014.04 r49378) ) #32 Sat Dec 24 22:01:05 CST 2016
[ 0.000000] Board has DDR2
[ 0.000000] Analog PMU set to hw control
[ 0.000000] Digital PMU set to hw control
[ 0.000000] SoC Type: MediaTek MT7628AN ver:1 eco:2
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
[ 0.000000] MIPS: machine is VoCore2
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 08000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x07ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x07ffffff]
[ 0.000000] Initmem setup node 0 [mem 0x00000000-0x07ffffff]
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 byt es
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pag es: 32512
[ 0.000000] Kernel command line: console=ttyS2,115200 rootfstype=squashfs,jff s2
[ 0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Writing ErrCtl register=0001d14c
[ 0.000000] Readback ErrCtl register=0001d14c
[ 0.000000] Memory: 126340K/131072K available (2530K kernel code, 131K rwdata , 520K rodata, 136K init, 186K bss, 4732K reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:256
[ 0.000000] intc: using register map from devicetree
[ 0.000000] CPU Clock: 580MHz
[ 0.000000] clocksource_of_init: no matching clocksources found
[ 0.000000] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[ 0.060000] pid_max: default: 32768 minimum: 301
[ 0.060000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.070000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.070000] pinctrl core: initialized pinctrl subsystem
[ 0.080000] NET: Registered protocol family 16
[ 0.100000] mt7621_gpio 10000600.gpio: registering 32 gpios
[ 0.110000] mt7621_gpio 10000600.gpio: registering 32 gpios
[ 0.110000] mt7621_gpio 10000600.gpio: registering 32 gpios
[ 0.120000] Switched to clocksource MIPS
[ 0.120000] NET: Registered protocol family 2
[ 0.130000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.130000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.140000] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.140000] TCP: reno registered
[ 0.150000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.150000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.160000] NET: Registered protocol family 1
[ 0.170000] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.180000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.190000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORIT Y) (c) 2001-2006 Red Hat, Inc.
[ 0.200000] msgmni has been set to 246
[ 0.210000] io scheduler noop registered
[ 0.210000] io scheduler deadline registered (default)
[ 0.220000] gdma-mt7628 10002800.gdma: revision: 3, channels: 16
[ 0.230000] Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
[ 0.230000] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
[ 0.240000] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2 500000) is a 16550A
[ 0.250000] console [ttyS2] disabled
[ 0.260000] 10000e00.uart2: ttyS2 at MMIO 0x10000e00 (irq = 30, base_baud = 2 500000) is a 16550A
[ 0.270000] console [ttyS2] enabled
[ 0.270000] console [ttyS2] enabled
[ 0.270000] bootconsole [early0] disabled
[ 0.270000] bootconsole [early0] disabled
[ 0.280000] spi-mt7621 10000b00.spi: sys_freq: 193333333
[ 0.290000] m25p80 spi32766.0: found gd25q128, expected en25q64
[ 0.300000] m25p80 spi32766.0: gd25q128 (16384 Kbytes)
[ 0.300000] m25p80 spi32766.0: using chunked io
[ 0.310000] 4 ofpart partitions found on MTD device spi32766.0
[ 0.320000] Creating 4 MTD partitions on "spi32766.0":
[ 0.320000] 0x000000000000-0x000000030000 : "u-boot"
[ 0.330000] 0x000000030000-0x000000040000 : "u-boot-env"
[ 0.330000] 0x000000040000-0x000000050000 : "factory"
[ 0.340000] 0x000000050000-0x000001000000 : "firmware"
[ 0.410000] 2 uimage-fw partitions found on MTD device firmware
[ 0.410000] 0x000000050000-0x000000167d92 : "kernel"
[ 0.420000] 0x000000167d92-0x000001000000 : "rootfs"
[ 0.420000] mtd: device 5 (rootfs) set to be root filesystem
[ 0.430000] 1 squashfs-split partitions found on MTD device rootfs
[ 0.440000] 0x0000006f0000-0x000001000000 : "rootfs_data"
[ 0.450000] ralink_soc_eth 10100000.ethernet: generated random MAC address ae :79:59:21:8a:b2
[ 0.460000] ralink_soc_eth 10100000.ethernet eth0: ralink at 0xb0100000, irq 5
[ 0.470000] mt7621_wdt 10000120.watchdog: Initialized
[ 0.480000] TCP: cubic registered
[ 0.480000] NET: Registered protocol family 17
[ 0.480000] bridge: automatic filtering via arp/ip/ip6tables has been depreca ted. Update your scripts to load br_netfilter if you need this.
[ 0.500000] 8021q: 802.1Q VLAN Support v1.8
[ 0.520000] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[ 0.520000] Freeing unused kernel memory: 136K (8031e000 - 80340000)
[ 2.320000] init: Console is alive
[ 2.320000] init: - watchdog -
[ 5.860000] usbcore: registered new interface driver usbfs
[ 5.860000] usbcore: registered new interface driver hub
[ 5.870000] usbcore: registered new device driver usb
[ 5.880000] exFAT: Version 1.2.9
[ 5.930000] SCSI subsystem initialized
[ 5.940000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 5.950000] ehci-platform: EHCI generic platform driver
[ 5.970000] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
[ 5.970000] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
[ 5.980000] ehci-platform 101c0000.ehci: EHCI Host Controller
[ 5.980000] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[ 5.990000] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[ 6.020000] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[ 6.020000] hub 1-0:1.0: USB hub found
[ 6.030000] hub 1-0:1.0: 1 port detected
[ 6.030000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 6.040000] ohci-platform: OHCI generic platform driver
[ 6.050000] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
[ 6.050000] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[ 6.060000] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[ 6.130000] hub 2-0:1.0: USB hub found
[ 6.130000] hub 2-0:1.0: 1 port detected
[ 6.150000] MTK MSDC device init.
[ 6.190000] mtk-sd: MediaTek MT6575 MSDC Driver
[ 6.190000] sdhci: Secure Digital Host Controller Interface driver
[ 6.200000] sdhci: Copyright(c) Pierre Ossman
[ 6.210000] sdhci-pltfm: SDHCI platform and OF driver helper
[ 6.220000] usbcore: registered new interface driver usb-storage
[ 6.450000] init: - preinit -
[ 7.600000] rt305x-esw 10110000.esw: link changed 0x00
[ 7.800000] random: mktemp urandom read with 13 bits of entropy available
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[ 11.060000] mount_root: loading kmods from internal overlay
[ 11.760000] jffs2: notice: (375) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 11.780000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[ 11.840000] block: extroot: not configured
[ 12.040000] jffs2: notice: (372) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 12.060000] mount_root: loading kmods from internal overlay
[ 12.580000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[ 12.630000] block: extroot: not configured
[ 12.630000] mount_root: switching to jffs2 overlay
[ 12.660000] procd: - early -
[ 12.660000] procd: - watchdog -
[ 13.470000] procd: - ubus -
[ 14.500000] procd: - init -
Please press Enter to activate this console.
[ 15.930000] NET: Registered protocol family 10
[ 15.990000] ntfs: driver 2.1.31 [Flags: R/O MODULE].
[ 16.050000] tun: Universal TUN/TAP device driver, 1.6
[ 16.050000] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[ 16.070000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 16.080000] i2c /dev entries driver
[ 16.990000] <-- RTMPAllocTxRxRingMemory, Status=0, ErrorValue=0x
[ 16.990000] <-- RTMPAllocAdapterBlock, Status=0
[ 17.030000] i2c-gpio i2c-gpio: using pins 5 (SDA) and 4 (SCL)
[ 17.050000] Linux video capture interface: v2.00
[ 17.090000] mt7628-i2s 10000a00.i2s: loaded, sys freq is 480MHz.
[ 17.100000] es8388_codec_probe
[ 17.100000] set system reference clock(mclk) to 12MHz.
[ 17.110000] mt7628-audio audio-card: es8388-hifi <-> 10000a00.i2s mapping ok
[ 17.130000] mt7628-audio audio-card: load
[ 17.150000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 17.170000] nf_conntrack version 0.5.0 (1976 buckets, 7904 max)
[ 17.250000] usbcore: registered new interface driver usblp
[ 17.280000] usbcore: registered new interface driver uvcvideo
[ 17.290000] USB Video Class driver (1.1.1)
[ 17.310000] xt_time: kernel timezone is -0000
[ 17.320000] PPP generic driver version 2.4.2
[ 17.330000] NET: Registered protocol family 24
[ 24.350000] device eth0.1 entered promiscuous mode
[ 24.360000] device eth0 entered promiscuous mode
[ 24.390000] br-lan: port 1(eth0.1) entered forwarding state
[ 24.390000] br-lan: port 1(eth0.1) entered forwarding state
[ 25.860000] efuse_probe: efuse = 10000002
[ 26.090000] tssi_0_target_pwr_g_band = 35
[ 26.090000] tssi_1_target_pwr_g_band = 35
[ 26.390000] br-lan: port 1(eth0.1) entered forwarding state
[ 33.030000] <==== rt28xx_init, Status=0
[ 33.930000] device ra0 entered promiscuous mode
[ 33.940000] br-lan: port 2(ra0) entered forwarding state
[ 33.940000] br-lan: port 2(ra0) entered forwarding state
[ 35.940000] br-lan: port 2(ra0) entered forwarding state
[ 58.560000] random: nonblocking pool is initialized



BusyBox v1.23.2 (2016-09-03 09:56:08 CST) built-in shell (ash)

herci
 
Posts: 27
Joined: Thu Dec 29, 2016 2:32 pm

Re: Setup AP + STA Mode

Mon Jan 09, 2017 8:58 pm

maybe this is useful too, I'm trying all sorts of stuff I found on google

without vi it was permission denied

root@OpenWrt:/# vi /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd1c:5a88:47dd::/48'

config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option macaddr 'b8:d8:12:67:13:e0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth0.2'
option force_link '1'
option macaddr 'b8:d8:12:67:13:e1'
option proto 'dhcp'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
- /etc/config/network 32/48 66%

cory
 
Posts: 35
Joined: Sun Dec 18, 2016 1:00 am

Re: Setup AP + STA Mode

Mon Jan 09, 2017 9:45 pm

your network doesn't have what mentions in step 5. of Setup AP + STA Mode section
http://vocore.io/v2u.html

herci
 
Posts: 27
Joined: Thu Dec 29, 2016 2:32 pm

Re: Setup AP + STA Mode

Mon Jan 09, 2017 9:58 pm

you're right,

did it again now

got this:



root@OpenWrt:/# uci set wireless.sta.ssid=[telenet-apn-D4F49]
et wireless.sta.key=[my password here]

uci set wireless.sta.network=wwan

uci sroot@OpenWrt:/#
root@OpenWrt:/# uci set wireless.sta.key=[this contains my password]
et wireless.sta.disabled=0

uci commit

/etc/init.d/network restart
sleep 1root@OpenWrt:/#
root@OpenWrt:/# uci set wireless.sta.network=wwan
0

uci set wireless.sta.disabled=1

uci commit

uci delete network.wwan

uci set nroot@OpenWrt:/#
root@OpenWrt:/# uci set wireless.sta.disabled=0
etwork.wwan=interface

uci set network.wwan.proto=dhcp

uci commit

uci del_list root@OpenWrt:/#
root@OpenWrt:/# uci commit
firewall.@zone[1].network=wwan

uci add_list firewall.@zone[1].network=wwan

uci set firewall.@zone[1].input=ACCEPT

uci set firewall.@zone[1].output=ACCEPT

uci set firewall.@zone[1].forward=ACCEPT

uci set firewall.@zone[1].masq=1

uci set firewall.@zone[1].mtu_fix=1

uci commit

uci delete network.wwan

uci set network.wwan=interface

uci set network.wwan.proto=dhcp

uci commit

/etc/init.d/network restartroot@OpenWrt:/#
root@OpenWrt:/# /etc/init.d/network restart
[ 368.970000] br-lan: port 2(ra0) entered disabled state
[ 368.980000] br-lan: port 1(eth0.1) entered disabled state
[ 369.000000] device eth0.1 left promiscuous mode
[ 369.000000] br-lan: port 1(eth0.1) entered disabled state
[ 369.010000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[ 369.020000] device ra0 left promiscuous mode
[ 369.020000] br-lan: port 2(ra0) entered disabled state
[ 369.270000] device eth0 left promiscuous mode
root@OpenWrt:/# sleep 10
[ 371.090000] device eth0.1 entered promiscuous mode
[ 371.090000] device eth0 entered promiscuous mode
[ 371.110000] br-lan: port 1(eth0.1) entered forwarding state
[ 371.110000] br-lan: port 1(eth0.1) entered forwarding state
[ 373.110000] br-lan: port 1(eth0.1) entered forwarding state
[ 373.180000] device ra0 entered promiscuous mode
[ 373.180000] br-lan: port 2(ra0) entered forwarding state
[ 373.190000] br-lan: port 2(ra0) entered forwarding state
[ 375.190000] br-lan: port 2(ra0) entered forwarding state
root@OpenWrt:/#
root@OpenWrt:/# uci set wireless.sta.disabled=1
root@OpenWrt:/#
root@OpenWrt:/# uci commit
root@OpenWrt:/#
root@OpenWrt:/# uci delete network.wwan
root@OpenWrt:/#
root@OpenWrt:/# uci set network.wwan=interface
root@OpenWrt:/#
root@OpenWrt:/# uci set network.wwan.proto=dhcp
root@OpenWrt:/#
root@OpenWrt:/# uci commit
root@OpenWrt:/#
root@OpenWrt:/# uci del_list firewall.@zone[1].network=wwan
root@OpenWrt:/#
root@OpenWrt:/# uci add_list firewall.@zone[1].network=wwan
root@OpenWrt:/#
root@OpenWrt:/# uci set firewall.@zone[1].input=ACCEPT
root@OpenWrt:/#
root@OpenWrt:/# uci set firewall.@zone[1].output=ACCEPT
root@OpenWrt:/#
root@OpenWrt:/# uci set firewall.@zone[1].forward=ACCEPT
root@OpenWrt:/#
root@OpenWrt:/# uci set firewall.@zone[1].masq=1
root@OpenWrt:/#
root@OpenWrt:/# uci set firewall.@zone[1].mtu_fix=1
root@OpenWrt:/#
root@OpenWrt:/# uci commit
root@OpenWrt:/#
root@OpenWrt:/# uci delete network.wwan
root@OpenWrt:/#
root@OpenWrt:/# uci set network.wwan=interface
root@OpenWrt:/#
root@OpenWrt:/# uci set network.wwan.proto=dhcp
root@OpenWrt:/#
root@OpenWrt:/# uci commit
root@OpenWrt:/#
root@OpenWrt:/# /etc/init.d/network restart
[ 387.240000] br-lan: port 2(ra0) entered disabled state
[ 387.250000] br-lan: port 1(eth0.1) entered disabled state
[ 387.270000] device eth0.1 left promiscuous mode
[ 387.270000] br-lan: port 1(eth0.1) entered disabled state
[ 387.280000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[ 387.300000] device ra0 left promiscuous mode
[ 387.300000] br-lan: port 2(ra0) entered disabled state
[ 387.550000] device eth0 left promiscuous mode
root@OpenWrt:/# [ 389.310000] device eth0.1 entered promiscuous mode
[ 389.320000] device eth0 entered promiscuous mode
[ 389.330000] br-lan: port 1(eth0.1) entered forwarding state
[ 389.330000] br-lan: port 1(eth0.1) entered forwarding state
[ 390.190000] device ra0 entered promiscuous mode
[ 390.200000] br-lan: port 2(ra0) entered forwarding state
[ 390.200000] br-lan: port 2(ra0) entered forwarding state
[ 391.330000] br-lan: port 1(eth0.1) entered forwarding state
[ 392.200000] br-lan: port 2(ra0) entered forwarding state
wifi
root@OpenWrt:/# [ 398.630000] ERROR!!! RTMPSetTimer failed, Halt in Progress!
[ 398.650000] br-lan: port 2(ra0) entered disabled state
[ 398.660000] device ra0 left promiscuous mode
[ 398.670000] br-lan: port 2(ra0) entered disabled state
[ 399.040000] efuse_probe: efuse = 10000002
[ 399.210000] tssi_0_target_pwr_g_band = 35
[ 399.210000] tssi_1_target_pwr_g_band = 35
[ 404.200000] <==== rt28xx_init, Status=0
[ 404.340000] device ra0 entered promiscuous mode
[ 404.340000] br-lan: port 2(ra0) entered forwarding state
[ 404.350000] br-lan: port 2(ra0) entered forwarding state
[ 406.350000] br-lan: port 2(ra0) entered forwarding state

kosmonaut pirx
 
Posts: 17
Joined: Mon Jan 02, 2017 11:35 pm

Re: Setup AP + STA Mode

Mon Jan 09, 2017 10:09 pm

herci wrote:I did all the commands from the first post again and I just copied the name of my wifi, to assure I made no mistakes in the following line
uci set wireless.sta.ssid=[telenet-apn-D4F49]

you talk about a etc/config/wireless command, but there isn't a command like this in the tutorial, did I forget something?


Ok, sorry, some wrong assumptions here.

First,
'/etc/config/wireless' is a config file at the flash drive, No command. As you already found out, you may edit it with e.g. 'vi' command or view it with 'less' command or 'more' command or 'cat' or maybe some other programs installed already. Those are some linux "default" programs, btw, you'll find them at almost any installed unix-like systems.

This config file describes your wifi config. Take a look at it.


Second,
the uci command you use should be
uci set wireless.sta.ssid='telenet-apn-D4F49'
or
uci set wireless.sta.ssid="telenet-apn-D4F49"
in case you have no special chars in the ssid (is this valid? don't know)

Absolutely NO square brackets at all! This might be intentional for some, but maybe an additional note in the wiki might help others.

Now that you can view the config file, you can see after an 'uci commit' how the configuration changes.


and Third, finally,
you can use the 'wifi' command to restart the wifi services. Unfortunately, someone put a "disabled" in the default '/etc/rc.local' file (exercise: take a look at it using e.g. 'cat' ) after 10seconds. You'll note that your STA interface in '/etc/config/wireless' always is set to disabled after some time (line: option disabled '1'). Took some time to find that and very annoying :( So in order to use 'wifi' command you may a) re-enable it (via uci or edit config file) or comment all stuff in /etc/rc.local' out. I did the latter.
If you don't do this, 'wifi' command does nothing with your STA resp. wifi access, as it is/was disabled. You've seen this already, don't you.

regards.

cory
 
Posts: 35
Joined: Sun Dec 18, 2016 1:00 am

Re: Setup AP + STA Mode

Mon Jan 09, 2017 10:12 pm

can you type cat /etc/config/network and post the result

Next
Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 49 guests