Error installing kmod- Kernel Modules (image 20161224.bin)

BastiOfBerlin
 
Posts: 1
Joined: Sun Jan 08, 2017 10:53 pm
Location: Berlin

Error installing kmod- Kernel Modules (image 20161224.bin)

Sun Jan 08, 2017 11:05 pm

Hi @all,

today I was trying to install the Kernel module kmod-bluetooth using opkg.

Previously I downloaded and flashed the latest Image (2016.12.24, md5:2a6b06ee7ec7b3fa6fd3e9eeb5c83531) from http://vocore.io/v2u.html.

Running
Code: Select all
root@OpenWrt:~# opkg install kmod-bluetooth

returns the following error:
Code: Select all
Installing kmod-bluetooth (3.18.23-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ramips/mt7628/packages/base/kmod-bluetooth_3.18.23-1_ramips_24kec.ipk.
[..]
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-bluetooth:
 *      kernel (= 3.18.23-1-245faaffbc60cabe96a158cae13c1cc3)
 * opkg_install_cmd: Cannot install package kmod-bluetooth.


From running
Code: Select all
root@OpenWrt:~# uname -a
Linux OpenWrt 3.18.29 #24 Mon Nov 14 11:36:06 CST 2016 mips GNU/Linux

I understand that my Kernel is NEWER than the compiled version of the package depends on.

Now, do I have any option to install that package other than building a new firmware on my own? And if I have to, which repo do I have to fork to start working and how can I pre-bundle additional packages in that case.

Thanks in advance! and
Best regards

Return to VoCore2

Who is online

Users browsing this forum: No registered users and 2 guests