Default Config VoCore2 Ultimate

betabrain
 
Posts: 3
Joined: Thu Jan 12, 2017 9:12 pm

Default Config VoCore2 Ultimate

Thu Jan 12, 2017 9:26 pm

Where can I find the default / factory configuration for the VoCore2 Ultimate? I managed to mess up its wifi config within minutes of first use (config change via graphical interface). And unfortunately the instructions on the STA+AP page don't help:

Code: Select all
root@OpenWrt:/# uci set wireless.sta.ssid=[HOMEWIFI]
uci: Invalid argument
root@OpenWrt:/# uci set wireless.sta.ssid='HOMEWIFI'
uci: Invalid argument
root@OpenWrt:/# uci set wireless.sta.ssid=HOMEWIFI
uci: Invalid argument

Vonger
 
Posts: 896
Joined: Sun Oct 19, 2014 6:00 am

Re: Default Config VoCore2 Ultimate

Fri Jan 13, 2017 2:06 pm

[HOMEWIFI] this means replace with your home router wireless hotspot name.

please paste three config here: /etc/config/wireless, /etc/config/firmware, /etc/config/network

betabrain
 
Posts: 3
Joined: Thu Jan 12, 2017 9:12 pm

Re: Default Config VoCore2 Ultimate

Mon Jan 16, 2017 11:11 am

/etc/config/wireless
Code: Select all
config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'CH'

config wifi-iface
        option device 'radio0'
        option network 'wifi'
        option mode 'ap'
        option ssid 'VoCore'
        option encryption 'psk2'
        option key 'superman12345'


/etc/config/firmware

Code: Select all
config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'


/etc/config/network

Code: Select all
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd47:f447:6340::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option macaddr '00:0c:43:e1:76:28'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option force_link '1'
        option macaddr '00:0c:43:e1:76:29'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'

config interface 'wifi'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

Vonger
 
Posts: 896
Joined: Sun Oct 19, 2014 6:00 am

Re: Default Config VoCore2 Ultimate

Tue Jan 17, 2017 12:41 am

Looks like it is normal, try firstboot -y and reboot your vocore, make the config back to default. check if it works.

betabrain
 
Posts: 3
Joined: Thu Jan 12, 2017 9:12 pm

Re: Default Config VoCore2 Ultimate

Tue Jan 17, 2017 12:16 pm

Thanks. The default config works. :D What is the recommended next step? Is there a firmware update I should do?

freaky2xd
 
Posts: 1
Joined: Thu Jan 26, 2017 5:05 pm

Re: Default Config VoCore2 Ultimate

Thu Jan 26, 2017 5:10 pm

hey I am a noob considering programming and stuff!
how exactly can I restore the vocore2+dock?
I messed up the settings and now there is no ap but the lights are both on...
I only know how to access the vocore via putty in order to get to the openwrt interface and then my knowledge is gone

Vonger
 
Posts: 896
Joined: Sun Oct 19, 2014 6:00 am

Re: Default Config VoCore2 Ultimate

Fri Jan 27, 2017 2:24 pm

freaky2xd wrote:hey I am a noob considering programming and stuff!
how exactly can I restore the vocore2+dock?
I messed up the settings and now there is no ap but the lights are both on...
I only know how to access the vocore via putty in order to get to the openwrt interface and then my knowledge is gone


First, connect your vocore to your computer, then install usb2ttl driver on vocore.io/v2, finally login to console by TTL and run firstboot -y

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 50 guests