No sound output via AirPlay

MacLemon
 
Posts: 2
Joined: Sun Mar 05, 2017 1:56 pm

No sound output via AirPlay

Sun Mar 05, 2017 2:30 pm

I've got a Vocore2 + audio dock via IGG.

I've already updated it to Firmware (2016.12.24) (md5:2a6b06ee7ec7b3fa6fd3e9eeb5c83531).
Code: Select all
# uname -a
Linux OpenWrt 3.18.29 #32 Sat Dec 24 22:01:05 CST 2016 mips GNU/Linux

When I copy an MP3 to the VoCore2 via SSH I can play it with madplay file.mp3 and I can hear the sound on my stereo. So I know my audio wiring is working correctly.

When connecting my laptop to the VoCore2 SSID I can select it as an AirPlay target in iTunes and start playing music. I can see the network connections to to the VoCore2.

On the VoCore2 I can see the system load rise from about 4% to around 15% which tells me that audio data is being decoded. Load immedeately drops when I pause music playback.

The problem is that I cannot hear the music when playing via AirPlay.

I've tried setting up audio via alsamixer which tells me there is nothing to configure, the 0 mt7628-audio-card is recognised. I can also see the device being selected.

Code: Select all
root@OpenWrt:/tmp# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: mt7628audiocard [mt7628-audio-card], device 0: audio-card es8388-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
root@OpenWrt:/tmp# aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=mt7628audiocard
    mt7628-audio-card,
    Default Audio Device
sysdefault:CARD=mt7628audiocard
    mt7628-audio-card,
    Default Audio Device


I've also tried setting the audio card as output device in /etc/shairport-sync.conf which did not make any difference. (The setting does stick after a reboot but doesn't seem to remedy the problem.)

Even though it seems I'm also suffering from the PCB airport antenna interference causing a crackling in the audio output. But I can probably solve that with an external antenna. My main problem is that AirPlay doesn't output sound at all.

What else could I try to get AirPlay to output sound?

Vonger
 
Posts: 709
Joined: Sun Oct 19, 2014 6:00 am

Re: No sound output via AirPlay

Wed Mar 08, 2017 2:41 pm

This is really weird.
Please check shairport config.
If audio output is normal, wireless transfer is normal, the only problem is shairport setting is wrong.


PS: But default setting works on every vocore as we tested. :)

MacLemon
 
Posts: 2
Joined: Sun Mar 05, 2017 1:56 pm

Re: No sound output via AirPlay

Sat Mar 18, 2017 8:43 pm

Thanks, that was what I was expecting. For some reason it did not work.

I got it fixed by reflashing the current firmware two more times. Now AirPlay is working. :)

I also do get the crackling and occasional break ups of the audio, like already mentioned in another thread. Touching the onboard antenna does help sometimes but not always.

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 4 guests