wifi client not working

billdurr
 
Posts: 5
Joined: Tue Jun 06, 2017 7:05 pm

wifi client not working

Tue Jun 13, 2017 7:16 pm

I'm trying to setup wifi client mode (station) an it does not appear to work. After configuring it, the interface never comes up, nor does the nic connect to the wireless network. After configuring, the iwinfo command lists nothing.

Code: Select all
config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'CN'
        option hwmode '11g'
        option htmode 'HT40'
        option channel 'auto'
        option disabled '0'

config wifi-iface 'ap'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option encryption 'none'
        option ssid 'VoCore2.1'
        option disabled '1'

config wifi-iface 'sta'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option led 'mediatek:orange:wifi'
        option ssid 'Tomato24'
        option encryption 'none'
        option disabled '0'
        option ifname 'apcli0'

GinDiamond
 
Posts: 39
Joined: Thu Mar 31, 2016 11:02 pm

Re: wifi client not working

Tue Jun 13, 2017 9:04 pm

In my experience, the best and easiest way to set up networks is through LuCi

overzelus
 
Posts: 5
Joined: Sat Sep 29, 2018 4:20 am

Re: wifi client not working

Mon Oct 15, 2018 4:56 am

I'm having pretty much exactly the same issue.

After attempting to configure station mode (using Vonger's mt7628.ko driver) there's no attempt to associate.
Even calling "/etc/init.d/network restart" is ineffective.

Anyone get station mode working on 18.06+? With either the mt76 or mt7628 driver?

Vonger
 
Posts: 677
Joined: Sun Oct 19, 2014 6:00 am

Re: wifi client not working

Mon Oct 15, 2018 8:34 am

better to use AP+STA and hide SSID...
mt7628 driver can not support pure STA mode as I know.

overzelus
 
Posts: 5
Joined: Sat Sep 29, 2018 4:20 am

Re: wifi client not working

Mon Oct 15, 2018 4:59 pm

I can't even get AP+STA mode functioning, though the goal (and a project requirement) is to run in station-only mode.
Thanks for letting me know mt7628 is a dead end.
I'll have to switch back to mt76.
I'm hoping station-only mode works with that driver?

overzelus
 
Posts: 5
Joined: Sat Sep 29, 2018 4:20 am

Re: wifi client not working

Tue Oct 16, 2018 5:31 am

After u-booting a stock-image (20170527.bin) and uploading the latest OpenWRT compilation, I get this mess:

Code: Select all
BusyBox v1.29.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r8328-39e5e17045
 -----------------------------------------------------
root@OpenWrt:/#
root@OpenWrt:/# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='ralink'
wireless.radio0.variant='mt7628'
wireless.radio0.country='CN'
wireless.radio0.hwmode='11g'
wireless.radio0.htmode='HT40'
wireless.radio0.channel='auto'
wireless.radio0.disabled='0'
wireless.ap=wifi-iface
wireless.ap.device='radio0'
wireless.ap.mode='ap'
wireless.ap.network='lan'
wireless.ap.ifname='ra0'
wireless.ap.ssid='VoCore2'
wireless.ap.encryption='none'
wireless.sta=wifi-iface
wireless.sta.device='radio0'
wireless.sta.mode='sta'
wireless.sta.network='wwan'
wireless.sta.ifname='apcli0'
wireless.sta.led='mediatek:orange:wifi'
wireless.sta.ssid='UplinkAp'
wireless.sta.key='SecretKey'
wireless.sta.encryption='psk'
wireless.sta.disabled='1'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.channel='11'
wireless.radio1.hwmode='11g'
wireless.radio1.path='platform/10300000.wmac'
wireless.radio1.htmode='HT20'
wireless.radio1.disabled='1'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='OpenWrt'
wireless.default_radio1.encryption='none'


So that doesn't go smoothly.
It's obvious the proprietary driver's configuration and the open-source driver don't quite mesh.
The result is a second radio entry that's probably mis-configured.
Flicking around a few settings to enable "radio1" while disabling "radio0" doesn't seem to affect anything.
I can't get the thing to beacon.

At the end of the day, I'm just looking to get an SPI peripheral attached to an existing wireless network in a semi-secure (WPA2-PSK), open-source manor.

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 4 guests