kmod-usb-printer problem

vzsze
 
Posts: 1
Joined: Sun Oct 15, 2017 10:49 am

kmod-usb-printer problem

Sun Oct 15, 2017 11:06 am

Following the Tutorial for USB-Printers, I noticed the following problems:

# opkg install kmod-usb-printer
Installing kmod-usb-printer (3.18.23-1) to root...
Downloading http://downloads.openwrt.org/chaos_calm ... _24kec.ipk.
Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-printer:
* kernel (= 3.18.23-1-245faaffbc60cabe96a158cae13c1cc3) *
* opkg_install_cmd: Cannot install package kmod-usb-printer.


Installing the driver with -nodeps works, but the module is not found, because it is installed in /lib/modules/3.18.23/usblp.ko, but the running kernel is 3.18.29. After copying the module to /lib/modules/3.18.29/usblp.ko it works.

Vonger
 
Posts: 672
Joined: Sun Oct 19, 2014 6:00 am

Re: kmod-usb-printer problem

Thu Oct 19, 2017 2:33 pm

Recompile the full openwrt will fix such issue, or you can try to directly load module to avoid that warning.
It is openwrt checking the driver version, but should not be a big issue.

Return to VoCore2

Who is online

Users browsing this forum: No registered users and 2 guests