disable mtk-sd warning

Valeron70
 
Posts: 5
Joined: Sat Dec 23, 2017 3:36 pm

disable mtk-sd warning

Tue Dec 26, 2017 6:25 am

I build openWRT from sources, but it show the kernel message
mtk-sd 10130000.sdhci: no support for card's volts

How to disable this messages without delete SD drivere?

Vonger
 
Posts: 659
Joined: Sun Oct 19, 2014 6:00 am

Re: disable mtk-sd warning

Sat Dec 30, 2017 9:09 am

This is because you do not have sd slot, you can remove sd card driver from your openwrt

markus.vocore
 
Posts: 10
Joined: Thu Mar 22, 2018 2:46 pm

Re: disable mtk-sd warning

Sun Apr 29, 2018 5:41 pm

Hi Vonger,

I have the same issue. After downloading OpenWrt from your page and building it (with default settings: Target System "Ralink TR288x/RT3xxx", Subtarget "MT7628 based boards", Target Profile "VoCore") and loading the compiled *sysupgrade.bin file, the VoCore2 is hanging during start-up with the following error:

Code: Select all
[    7.860000] mtk-sd 10130000.sdhci: no support for card's volts
[    7.860000] mmc0: error -22 whilst initialising MMC card


Can you PLEASE tell me how I can "remove the SD card driver from your OpenWrt"? I cannot find the settings in the menuconfig!

Thanks!

Markus

markus.vocore
 
Posts: 10
Joined: Thu Mar 22, 2018 2:46 pm

Re: disable mtk-sd warning

Sun Apr 29, 2018 7:17 pm

By-the-way, I just found your blog about the same issue: http://vonger.cn/?p=14457

I don't understand your "fist solution", how I can
call “rmmod mtk_sd” in console

if the VoCore is not starting up because of the error... I guess with "console" you mean the device console (e.g. by connecting to the device with serial terminal), right?

Further I tried your third solution:
Or third way, compile your own firmware without mtk_sd.

I wasn't able to find a mtk_sd setting in menuconfig. What was your approach?

What is the correct way to handle the mtk-sd error?

Vonger
 
Posts: 659
Joined: Sun Oct 19, 2014 6:00 am

Re: disable mtk-sd warning

Mon Apr 30, 2018 1:09 pm

It is kmod-mt7620-mmc in Kernel Modules -> Other submenu.

markus.vocore
 
Posts: 10
Joined: Thu Mar 22, 2018 2:46 pm

Re: disable mtk-sd warning

Wed May 02, 2018 12:48 pm

I had to disable the following settings in menuconfig >> Kernel Modules >> Other Modules:
* kmod-mmc
* kmod-sdhci
* kmod-sdhci-mt7620

Return to VoCore2

Who is online

Users browsing this forum: No registered users and 4 guests