LAN WiFi Bridge issue

cyberhippy
 
Posts: 2
Joined: Thu Jan 25, 2018 8:09 pm

LAN WiFi Bridge issue

Thu Jan 25, 2018 8:33 pm

I am using a VoCore2 + Ultimate dock and try to create a simple WiFi Access Point. But I failed on two points.
1. I can not connect the bridge to the wireless interface. I have tried may setup configuration with temporary success. All attempts started from factory settings:
Assign a static IP address to the predefined bridge interface 'LAN'
Connect 'LAN' bridge to the interfaces eth0.1 and ra0
Move eth0 to vlan1
Disable 'WAN' and 'WAN6'
Disable DHCP server
Disable firewall
Setup AP mode with desired SSID
This configuration worked some random times and will most certainly not survive a reboot.
The problem her is the WiFi AP interface. It broadcast SSID and can be connected to provided that the client has a static IP. But there is no network connectivity after that, even the IP address of the 'LAN' bridge is not reachable. During the odd case when I got it to work by playing with the settings, there is not problem and the DHCP request from the Client is forwarded and everything thereafter too.
2. I am also trying use the U.FL antenna connector. The documentation here is pure, I would like to use the U.FL antenna only and disable the or-board antenna. Any suggestion how to do that?
using the ant2.sh script here has no influence on the problem in 1.
As an aside I noticed that the LuCI interface shown the AP Signal and Noise. whereby the Signal remains at -256dBm and Noise seems to show the Signal strength. At lest after ant2.sh.
Could this be patched?

Thank you.

Vonger
 
Posts: 627
Joined: Sun Oct 19, 2014 6:00 am

Re: LAN WiFi Bridge issue

Sat Jan 27, 2018 7:37 am

2. this can be patched, I think lua script read from wrong section so it can not get correct SSID.

cyberhippy
 
Posts: 2
Joined: Thu Jan 25, 2018 8:09 pm

Re: LAN WiFi Bridge issue

Sun Jan 28, 2018 5:21 pm

Hi Vonger,

When you say that 2. can be patched, do you refer to the signal level observation or to the antenna configuration request?

my request for 2. is that I can do the following in

/etc/config/wireless

Code: Select all
config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'CN'
        option hwmode '11g'
        option disabled '0'
        option channel '8'
        option txantenna '1' # 1 = onboard antenna, 2 = U.FL antenna
        option rxantenna '2'  # 1 = onboard antenna, 2 = U.FL antenna


If possible it would be great if all four options work:
TX & RX onboard antenna (default)
option txantenna '1'
option rxantenna '1'

TX & RX U.FL antenna
option txantenna '2'
option rxantenna '2'

TX onboard antenna & RX U.FL antenna
option txantenna '1'
option rxantenna '2'

TX U.FL antenna & RX onboard antenna
option txantenna '2'
option rxantenna '1'

TX & RX antenna auto select possible?


Regarding issue 1. I found that a /etc/init.d/network restart after boot fixes the issue. Can this be fixed in way that ra0 joins the bridge when it becomes ready?

See boot log:
Code: Select all
[   19.770000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   19.790000] nf_conntrack version 0.5.0 (1976 buckets, 7904 max)
[   19.840000] usbcore: registered new interface driver uvcvideo
[   19.850000] USB Video Class driver (1.1.1)
[   19.890000] xt_time: kernel timezone is -0000
[   19.920000] PPP generic driver version 2.4.2
[   19.950000] NET: Registered protocol family 24
[   22.300000] rt305x-esw 10110000.esw: link changed 0x00
[   24.880000] ERROR!!! RTMPReadParametersHook failed, Status[=0x00000001]
[   24.910000] IPv6: ADDRCONF(NETDEV_UP): ra0: link is not ready
[   25.000000] device eth0.1 entered promiscuous mode
[   25.010000] device eth0 entered promiscuous mode
[   25.040000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   25.160000] br-lan: port 1(eth0.1) entered forwarding state
[   25.170000] br-lan: port 1(eth0.1) entered forwarding state
[   25.210000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   25.330000] ERROR!!! RTMPReadParametersHook failed, Status[=0x00000001]
-->[   25.360000] IPv6: ADDRCONF(NETDEV_UP): ra0: link is not ready<--
[   26.260000] rt305x-esw 10110000.esw: link changed 0x01
[   26.570000] efuse_probe: efuse = 10000002
[   26.790000] tssi_0_target_pwr_g_band = 35
[   26.790000] tssi_1_target_pwr_g_band = 35
[   26.840000] <==== rt28xx_init, Status=0
[   27.170000] br-lan: port 1(eth0.1) entered forwarding state
[   52.030000] random: nonblocking pool is initialized



BusyBox v1.23.2 (2016-09-03 09:56:08 CST) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Chaos Calmer, r49378)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# /etc/init.d/network restart
[   82.040000] br-lan: port 1(eth0.1) entered disabled state
[   82.060000] device eth0.1 left promiscuous mode
[   82.060000] device eth0 left promiscuous mode
[   82.070000] br-lan: port 1(eth0.1) entered disabled state
[   82.080000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[   83.200000] rt305x-esw 10110000.esw: link changed 0x00
root@OpenWrt:/# [   84.650000] IPv6: ADDRCONF(NETDEV_UP): ra0: link is not ready
[   84.970000] efuse_probe: efuse = 10000002
[   85.130000] tssi_0_target_pwr_g_band = 35
[   85.140000] tssi_1_target_pwr_g_band = 35
[   85.170000] <==== rt28xx_init, Status=0
[   85.170000] device ra0 entered promiscuous mode
[   85.180000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   85.200000] device eth0.1 entered promiscuous mode
[   85.210000] device eth0 entered promiscuous mode
[   85.210000] br-lan: port 2(eth0.1) entered forwarding state
[   85.220000] br-lan: port 2(eth0.1) entered forwarding state
[   85.220000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
-->[   85.640000] br-lan: port 1(ra0) entered forwarding state<--
-->[   85.640000] br-lan: port 1(ra0) entered forwarding state<--
[   87.140000] rt305x-esw 10110000.esw: link changed 0x01
[   87.220000] br-lan: port 2(eth0.1) entered forwarding state
-->[   87.640000] br-lan: port 1(ra0) entered forwarding state<--


with many thanks

Vonger
 
Posts: 627
Joined: Sun Oct 19, 2014 6:00 am

Re: LAN WiFi Bridge issue

Tue Jan 30, 2018 4:16 pm

that is not possible to control the antennas as I know.
you can only control tx power.

Return to VoCore2

Who is online

Users browsing this forum: No registered users and 4 guests