Not booting if using UART1

markus.vocore
 
Posts: 10
Joined: Thu Mar 22, 2018 2:46 pm

Not booting if using UART1

Fri May 11, 2018 9:06 am

Hello

We are using 2x UART:
- UART2 (RXD2 / TXD2) for debugging console and for programming
- UART1 (RXD1 / TXD1) for communication with an IC

The VoCore2 is not booting anymore, if UART1 is connected. See console output below. What is happening here and what can I do to use UART1?

Thanks!
Markus

============================================
Ralink UBoot Version: 4.3.0.0
--------------------------------------------
ASIC 7628_MP (Port5<->None)
DRAM component: 1024 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 128 MBytes
Flash component: SPI Flash
Date:Jun 25 2016 Time:22:54:33
============================================
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768
RESET MT7628 PHY!!!!!!
Please choose the operation:
0: Load system code then write to Flash via SERIAL.
1: Load system code to SDRAM via TFTP.
2: Load system code then write to Flash via TFTP.
3: Boot system code via Flash (default).
4: Entr boot command line interface.
5: Load system code then write to Flash via USB Storage.
7: Load Boot Loader code then write to Flash via Serial.
8: Start Web Server to load system code.
9: Load Boot Loader code then write to Flash via TFTP.
gpio trigger enabled
GPIO 46 used to trigger webpage
Hold button for between 3 seconds and 6 seconds
then release to trigger webpage to load image
Hold button for between 6 seconds and 9 seconds
then release to trigger loading image from USBSTORAGE
GPIO 46 is high
10 release GPIO 46 now for web load
10 release GPIO 46 now for usb load
10 too late

Vonger
 
Posts: 659
Joined: Sun Oct 19, 2014 6:00 am

Re: Not booting if using UART1

Sat May 12, 2018 2:49 am

Please use this uboot(you can change uboot by select 7 at start up)
http://vonger.cn/misc/vocore2/uboot.20180427.bin

markus.vocore
 
Posts: 10
Joined: Thu Mar 22, 2018 2:46 pm

Re: Not booting if using UART1

Mon May 14, 2018 12:17 pm

Works perfect, thank you!

Return to VoCore2

Who is online

Users browsing this forum: No registered users and 2 guests