Problem with SPI

ElPolloLoco
 
Posts: 1
Joined: Wed May 23, 2018 10:53 am

Problem with SPI

Wed May 23, 2018 2:07 pm

Hey,

I'm working on a simple communication between a VoCore2 and an Arduino UNO via SPI. Unfortunately thats a bigger task for me then I thought. The first problem occuerd during the SPI driver installation on OpenWRT. Is there a way to install the packages for SPI on a 3.18.29 kernel?
Or even better did anyone knows about a "how to" guide for using SPI between VoCore and Arduino?


Code: Select all
root@OpenWrt:/# opkg install kmod-mmc-spi
Installing kmod-mmc-spi (3.18.23-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ramips/mt7628/packages/base/kmod-mmc-spi_3.18.23-1_ramips_24kec.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-mmc-spi:
 *      kernel (= 3.18.23-1-245faaffbc60cabe96a158cae13c1cc3) *         kernel (= 3.18.23-1-245faaffbc60cabe96a158cae13c1cc3) *         kernel (= 3.18.23-1-245faaffbc60cabe96a158cae13c1cc3) *  kernel (= 3.18.23-1-245faaffbc60cabe96a158cae13c1cc3) *
 * opkg_install_cmd: Cannot install package kmod-mmc-spi.


Code: Select all
root@OpenWrt:/# uname -a
Linux OpenWrt 3.18.29 #6 Sat May 27 17:23:12 CST 2017 mips GNU/Linux


thank you in advance,
ElPolloLoco

Vonger
 
Posts: 659
Joined: Sun Oct 19, 2014 6:00 am

Re: Problem with SPI

Wed May 23, 2018 11:31 pm

This needs to compile from source code and enable SPI CS1(default SPI is used by flash) mmc-spi is used to connect to sd card in mmc mode.

Return to VoCore2

Who is online

Users browsing this forum: No registered users and 2 guests