OpenWRT 18.06.0 images for vocore/vocore2

kloczek
 
Posts: 15
Joined: Sat Jul 16, 2016 7:09 pm

OpenWRT 18.06.0 images for vocore/vocore2

Wed Aug 01, 2018 8:54 pm

I'm noit sure but looks like still there is no OpenWRT 18.06.0 images for vocore/vocore2.
Am I right?
https://openwrt.org/toh/bt/vg3503j/
https://downloads.openwrt.org/releases/ ... iq/xrx200/

vshymanskyy
 
Posts: 1
Joined: Sun Sep 23, 2018 6:19 pm

Re: OpenWRT 18.06.0 images for vocore/vocore2

Sun Sep 23, 2018 6:23 pm


GinDiamond
 
Posts: 47
Joined: Thu Mar 31, 2016 11:02 pm

Re: OpenWRT 18.06.0 images for vocore/vocore2

Mon Oct 01, 2018 3:37 pm

Is there a way to get i2c-tools on this? There doesn't seem to be a package for it anymore

Vonger
 
Posts: 697
Joined: Sun Oct 19, 2014 6:00 am

Re: OpenWRT 18.06.0 images for vocore/vocore2

Wed Jan 09, 2019 12:20 pm

GinDiamond wrote:Is there a way to get i2c-tools on this? There doesn't seem to be a package for it anymore

You can easily compile from source code, use this Makefile. openwrt one looks like broken because somebody add python library to it, compile it will use 10MB flash :[

#
# Copyright (C) 2007-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#

include $(TOPDIR)/rules.mk

PKG_NAME:=i2c-tools
PKG_VERSION:=3.1.2
PKG_RELEASE:=1

PKG_SOURCE_URL:=@KERNEL/software/utils/i2c-tools
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_HASH:=6d6079153cd49a62d4addacef4c092db1a46ba60b2807070a3fbe050262aef87

PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=COPYING

include $(INCLUDE_DIR)/package.mk

define Package/i2c/Default
URL:=http://lm-sensors.org/wiki/I2CTools
TITLE:=I2C
endef

define Package/i2c-tools
$(call Package/i2c/Default)
SECTION:=utils
CATEGORY:=Utilities
TITLE+=tools for Linux
endef

define Package/i2c-tools/description
This package contains an heterogeneous set of I2C tools for Linux. These tools
were originally part of the lm-sensors package.
endef

define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
LINUX="$(LINUX_DIR)" \
CC="$(TARGET_CC)" \
STAGING_DIR="$(STAGING_DIR)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
CFLAGS="$(TARGET_CFLAGS)"
endef

define Package/i2c-tools/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/i2cdetect $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/i2cdump $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/i2cset $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/i2cget $(1)/usr/sbin/
endef


$(eval $(call BuildPackage,i2c-tools))

velo
 
Posts: 5
Joined: Mon Jan 30, 2017 8:02 am

Re: OpenWRT 18.06.0 images for vocore/vocore2

Mon Jan 14, 2019 2:42 pm

If I may attach to this issue... I'm facing the same question: thank you for the Makefile. Can you give any pointers where this needs to go?

ICore
 
Posts: 16
Joined: Wed Jan 11, 2017 2:42 am

Re: OpenWRT 18.06.0 images for vocore/vocore2

Mon Jan 21, 2019 2:43 am

how about for vocore2 ultimate ?

Vonger
 
Posts: 697
Joined: Sun Oct 19, 2014 6:00 am

Re: OpenWRT 18.06.0 images for vocore/vocore2

Sun Jan 27, 2019 10:40 am

Firmware based on openwrt 18.06.1 now is valid.
Please download from http://vonger.cn/misc/vocore2/20190127.bin, it is based on openwrt 18.06.1
Tutorials at http://vonger.cn/?p=14633

Compatible with VoCore2 and VoCore2 Ultimate, Lite is not ready, but soon.

ArkEngr
 
Posts: 29
Joined: Tue Oct 20, 2015 1:58 pm

Re: OpenWRT 18.06.0 images for vocore/vocore2

Wed Jan 30, 2019 2:25 am

Since updating to the image for 18.06 on the blog, I can not get the wired port to work. It will not do DHCP, when changing to static IP, it still does not work. Old firmware worked.

ArkEngr
 
Posts: 29
Joined: Tue Oct 20, 2015 1:58 pm

Re: OpenWRT 18.06.0 images for vocore/vocore2

Wed Jan 30, 2019 10:48 pm

fixed per below:
root@OpenWrt:/etc/config# cat network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd5e:3f4a:4d67::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.61.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_dev'
option name 'eth0.1'
option macaddr 'b8:d8:12:67:6c:3a'

config interface 'wan'
option ifname 'eth0.2'
option force_link '1'
option proto 'dhcp'

config device 'wan_dev'
option name 'eth0.2'
option macaddr 'b8:d8:12:67:6c:39'

config interface 'wwan'
option ifname 'apcli0'
option proto 'dhcp'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'

config interface 'wwan'
option proto 'dhcp'
option hostname 'VocoreR2'

I think the issue is in the switch statements

Vonger
 
Posts: 697
Joined: Sun Oct 19, 2014 6:00 am

Re: OpenWRT 18.06.0 images for vocore/vocore2

Sat Feb 02, 2019 2:32 pm

Answer old question first, i2c-tools makefile, you can create a folder in openwrt/package named i2c-tools and touch a Makefile, put that data in, then you make menuconfig you will find it in Utilities. If you still confuse, you can check other files in package folder, they are similar.

For more study, you can reference to openwrt Makefile tutorial...that tutorial is not easy to understand I have to say(even hard than my Electrodynamics books), better to directly read the source code of the system in openwrt/rules.mk.(actually it is no better)

For new question: I guess only port 0 works...but this setting has 0,1,2,3,4...not correct.
VLAN1 is that eth0.1, VLAN2 is that eth0.2. looks like you put port 0 for both VLAN, you can find port 0 at option ports '0 1 2 3 4 6t' and also option ports '0 6t' so it confused, it do not know it is wan or lan, then you can not connect to it.

I am also not good at setting vlan, it is too hard for me :) over five years I still do not know what that '6t' function in the setting. :)

Next
Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 3 guests