Sound on VoCore2

Posts: 1
Joined: Sat Aug 04, 2018 12:47 pm

Sound on VoCore2

Sat Aug 04, 2018 1:23 pm

I tried to get the sound on my VoCore2 working...

But i did not succeed to get any sound out of it:

Here is what I tried:

- Image
Result: /dev/audio is there,
“madplay test.mp3” gives only tickling noise

root@OpenWrt:/tmp# dmesg | grep -E "i2c|i2s|audio|audio|8388"
[ 0.090000] rt2880-pinmux pinctrl: found group selector 4 for i2c
[ 17.770000] i2c /dev entries driver
[ 19.460000] i2c-gpio i2c-gpio: using pins 5 (SDA) and 4 (SCL)
[ 19.550000] mt7628-i2s 10000a00.i2s: loaded, sys freq is 480MHz.
[ 19.580000] es8388_codec_probe
[ 19.590000] mt7628-audio audio-card: es8388-hifi <-> 10000a00.i2s mapping ok
[ 19.600000] mt7628-audio audio-card: load
[ 46.400000] es8388_hw_params: 44100Hz 16bit, ADC: 0, DAC: 1
[ 46.410000] set audio rate to 44100Hz.

- Image
Result: No /dev/audio
- Image
Result no /dev/audio
opkg install kmod-sound-mt7620
still no /dev/audio
dmesg | grep -E "i2c|i2s|audio|audio|8388|mt7620"
[ 141.721199] i2c /dev entries driver
[ 141.771884] ralink-i2s 10000a00.i2s: mclk 480KHz
- I also tried to compile latest openwrt with the kmod-sound-mt7620, but this also does not work

What did i do wrong?

Posts: 825
Joined: Sun Oct 19, 2014 6:00 am

Re: Sound on VoCore2

Sat Aug 04, 2018 4:35 pm

20180723V.bin do not have audio driver yet, try 20170527V.bin.
If madplay do not work, that is possible hardware issue. Please check if there is anything broken.

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 5 guests