18.06.2 Fails to build

Posts: 1
Joined: Mon Jun 10, 2019 10:29 pm

Re: 18.06.2 Fails to build

Mon Jun 10, 2019 10:32 pm

Hi everyone, do you know if its possible to install ubuntu on vocore2 and run tomcat and mysql? if its possible, do you have a tutorial or informatio to achieve that task? Thanks in advance

Posts: 786
Joined: Sun Oct 19, 2014 6:00 am

Re: 18.06.2 Fails to build

Tue Jun 11, 2019 3:58 pm

It is not possible, vocore2 do not have enough memory for them.
But you can use openwrt replace ubuntu and use sqlite3 replace mysql.
Same function.

Posts: 13
Joined: Tue Dec 03, 2019 4:07 pm

Re: 18.06.2 Fails to build

Tue Dec 10, 2019 5:23 pm

Hello World!

It seems that I have the same error.
I've seen that could be avoided by building the kernel and after that we copy the patches, but does that make sense?

Code: Select all
make[4]: Entering directory '/home/fm/openwrt/build_dir/target-mipsel_24kc_musl/hostapd-full-internal/hostapd-2018-05-21-62566bc2/hostapd'
../src/ap/sta_info.o: In function `ap_sta_add':
sta_info.c:(.text.ap_sta_add+0x12e): undefined reference to `[b]sta_track_claim_taxonomy_info[/b]'
collect2: error: ld returned 1 exit status
Makefile:1298: recipe for target 'hostapd' failed
make[4]: *** [hostapd] Error 1
make[4]: Leaving directory '/home/fm/openwrt/build_dir/target-mipsel_24kc_musl/hostapd-full-internal/hostapd-2018-05-21-62566bc2/hostapd'
Makefile:577: recipe for target '/home/fm/openwrt/build_dir/target-mipsel_24kc_musl/hostapd-full-internal/hostapd-2018-05-21-62566bc2/.built' failed
make[3]: *** [/home/fm/openwrt/build_dir/target-mipsel_24kc_musl/hostapd-full-internal/hostapd-2018-05-21-62566bc2/.built] Error 2
make[3]: Leaving directory '/home/fm/openwrt/package/network/services/hostapd'
time: package/network/services/hostapd/full-internal/compile#0.51#0.12#1.00
package/Makefile:111: recipe for target 'package/network/services/hostapd/compile' failed
make[2]: *** [package/network/services/hostapd/compile] Error 2
make[2]: Leaving directory '/home/fm/openwrt'
package/Makefile:107: recipe for target '/home/fm/openwrt/staging_dir/target-mipsel_24kc_musl/stamp/.package_compile' failed
make[1]: *** [/home/fm/openwrt/staging_dir/target-mipsel_24kc_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/fm/openwrt'
/home/fm/openwrt/include/toplevel.mk:216: recipe for target 'world' failed
make: *** [world] Error 2

Posts: 13
Joined: Tue Dec 03, 2019 4:07 pm

Re: 18.06.2 Fails to build

Tue Dec 10, 2019 5:44 pm


In step 3:
Instead of "make menuconfig" and modifying the stock .config,
I did "cp ./package/vocore2/.config ./", and then modified the customized .config, and then I did make it.

Yes another error came up, but at least that was solved :)

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 2 guests