Cannot install any packages

rover
 
Posts: 1
Joined: Wed Feb 20, 2019 1:47 pm

Cannot install any packages

Wed Feb 20, 2019 1:54 pm

When I try to install most of additional packages I have the same error like this:
---------------------------------
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-printer:
* kernel (= 4.14.95-1-fa0ac614032ecce6935c8737b30999bb)
* opkg_install_cmd: Cannot install package kmod-usb-printer.
---------------------------------

Firmware Version OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)
Kernel Version 4.14.95

What problem?

Vonger
 
Posts: 742
Joined: Sun Oct 19, 2014 6:00 am

Re: Cannot install any packages

Wed Feb 20, 2019 2:43 pm

Hi, this is because kernel module is not compatible. You have to compile it from source code, looks like it is kind of kernel encryption. (compile tutorial at github.com/vonger/vocore2 and vonger.cn)
Or you can try opkg install kmod-usb-printer --force-depends, this sometimes cause kernel crash...

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 4 guests