Unable to compile 18.06.5

hazardousracerx
 
Posts: 1
Joined: Sun Mar 01, 2020 4:44 am

Unable to compile 18.06.5

Mon Mar 02, 2020 5:15 am

I have attempted multiple times to compile the firmware following the instructions on:
https://github.com/Vonger/vocore2

Every time It has failed to compile with various error messages.
I spun up a fresh (clean/new) minimal install VM of Ubuntu 19.10, installed the required packages according to the OpenWRT readme file, followed the instructions in the Vocore2 Github readme and it has failed to compile every time (5 times today).

Most recent tail of the error log below any ideas on how to fix it?

Code: Select all
Applying /home/user/workspace/openwrt/target/linux/ramips/patches-4.14/811-spi-gpio-chip-select.patch using plaintext:
patching file drivers/spi/spi-mt7621.c
Hunk #1 FAILED at 23.
Hunk #2 FAILED at 107.
Hunk #3 succeeded at 312 (offset -71 lines).
Hunk #4 FAILED at 446.
3 out of 4 hunks FAILED -- saving rejects to file drivers/spi/spi-mt7621.c.rej
Patch failed!  Please fix /home/user/workspace/openwrt/target/linux/ramips/patches-4.14/811-spi-gpio-chip-select.patch!

Vonger
 
Posts: 812
Joined: Sun Oct 19, 2014 6:00 am

Re: Unable to compile 18.06.5

Tue Mar 03, 2020 8:28 am

811-spi-gpio-chip-select.patch is not a necessary patch.
You can directly remove it, then it will able to compile.

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: Google [Bot] and 3 guests