Trying to install GCC

Posts: 3
Joined: Wed Nov 19, 2014 1:25 am

Trying to install GCC

Fri May 01, 2020 4:36 am

I have a Vocore2Ultimate.
I just updated the firmware to
I set up AP and STA Mode. instructions here:
I have the MicroSD mounted on /overlay. instructions here:
root@OpenWrt:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock6 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
/dev/mmcblk0 on /overlay type ext4 (rw,relatime,data=ordered)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
root@OpenWrt:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 3.0M 3.0M 0 100% /rom
tmpfs 61.0M 652.0K 60.4M 1% /tmp
/dev/mtdblock6 14.5G 41.4M 13.7G 0% /overlay
overlayfs:/overlay 11.4M 11.3M 176.0K 98% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mmcblk0 14.5G 41.4M 13.7G 0% /overlay

When I go to install GCC, (instructions here also: I get a disk full error:
Collected errors:
* pkg_write_filelist: Failed to open //usr/lib/opkg/info/gcc.list: No space left on device.
* opkg_install_pkg: Failed to extract data files for gcc. Package debris may remain!
* opkg_install_cmd: Cannot install package gcc.
* opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: No space left on device

I don't understand what /overlay does. There were sub-directories in it before I mounted the MicroSD card over it:
root@OpenWrt:~# cd /overlay/
root@OpenWrt:/overlay# ls *
bin etc mnt usr


I don't know what to do to make this work. ' Pretty new to this stuff.
Can someone guide me?


Posts: 842
Joined: Sun Oct 19, 2014 6:00 am

Re: Trying to install GCC

Mon May 04, 2020 12:57 pm

Looks like SD card is not correctly mount into /overlay folder, because I find your df command returned /overlay folder space is still 11.4MB(so it is NOR flash). If mount correctly it should be xxxxxMB
Can you try a USB disk?
/overlay as I know is an openwrt special filesystem, you can find some clues at openwrt official site.

Posts: 3
Joined: Wed Nov 19, 2014 1:25 am

Re: Trying to install GCC

Mon May 04, 2020 3:55 pm

I got it working. I had the mount file set up wrong. It all worked after I worked with hit some more.

Thanks for the reply!


Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: Google [Bot] and 1 guest