Can't connect to my wifi network

lamenace
 
Posts: 17
Joined: Wed Mar 04, 2015 3:18 pm

Can't connect to my wifi network

Wed Mar 04, 2015 4:11 pm

Hi,

I've changed my VoCore to sta mode to connect to my wifi network, but it fails to start link.

[ 1487.530000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

> network file:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'wlan0'
option ifname 'wlan0'
option macaddr 'b8:d8:12:60:00:01'
option proto 'dhcp'

config globals 'globals'
option ula_prefix 'fd02:649d:5a81::/48'

> wireless file
config wifi-device 'radio0'
option type 'mac80211'
option channel 'auto'
option hwmode '11g'
option path '10180000.wmac'
option htmode 'HT40'
option txpower '20'

config wifi-iface
option device 'radio0'
option network 'wlan0'
option mode 'sta'
option ssid 'xxxxx'
option encryption 'psk2'
option key 'xxxxxxxx'

Vonger
 
Posts: 842
Joined: Sun Oct 19, 2014 6:00 am

Re: Can't connect to my wifi network

Thu Mar 05, 2015 10:34 am

do you add firewall access?

You need to update three files to enable sta mode:
1. /etc/config/wireless
2. /etc/config/network
3. /etc/config/firewall

Please check wiki AP+STA, the STA part will help.
http://vocore.io/wiki/index/id:17

lamenace
 
Posts: 17
Joined: Wed Mar 04, 2015 3:18 pm

Re: Can't connect to my wifi network

Thu Mar 05, 2015 2:51 pm

It's ok now, I did this

root@OpenWrt:~# uci set wireless.@wifi-iface[0].encryption=psk
root@OpenWrt:~# uci set wireless.@wifi-iface[0].key="your_password"
root@OpenWrt:~# uci commit wireless
root@OpenWrt:~# wifi

Return to VoCore & VoCore+Dock

Who is online

Users browsing this forum: No registered users and 4 guests