I2C on Vocore 2 Ultimate

GinDiamond
 
Posts: 48
Joined: Thu Mar 31, 2016 11:02 pm

I2C on Vocore 2 Ultimate

Tue Aug 21, 2018 1:46 pm

I'd like to make my own flight controller with a vocore to control servos, gps, and a 9dof.
I need i2c ability to communicate with the 9dof and possibly the gps (if not uart).

However, when I try to do i2c-tools, it gives me an error:

Code: Select all
root@OpenWrt:~# i2cdetect -y 0
-ash: i2cdetect: not found
root@OpenWrt:~#


I try to do the suggested install:

Code: Select all
root@OpenWrt:~# opkg install i2c-tools
Unknown package 'i2c-tools'.
Collected errors:
 * opkg_install_cmd: Cannot install package i2c-tools.
root@OpenWrt:~# opkg install i2c-dev
Unknown package 'i2c-dev'.
Collected errors:
 * opkg_install_cmd: Cannot install package i2c-dev.


What can I do?

Vonger
 
Posts: 754
Joined: Sun Oct 19, 2014 6:00 am

Re: I2C on Vocore 2 Ultimate

Sun Jul 14, 2019 4:00 pm

this i2c-tool package has submit to github.com/vonger/vocore2, you can directly compile it in openwrt "make menuconfig" after install it.

also you can download i2c-tools from download.openwrt.org official site, but that magically depends on python...pretty big package and not necessary really.

Also i2c driver has updated, replace exists openwrt driver, now i2c-tool can work normal with it.
the patch is also in my github, feel free to submit to openwrt trunk if you test it ok.

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 8 guests