AP Isolation

vaticanuk
 
Posts: 2
Joined: Tue Aug 27, 2019 8:37 pm

AP Isolation

Tue Aug 27, 2019 8:50 pm

All clients connected to my VoCore2 (Ultimate running 18.06.04 using the instructions from here: http://vonger.cn/?p=14669) cannot see each other.

I've spent a number of evenings reading around the OpenWRT forums (I couldn't find anything here), where people suggested enabling hairpinning on the wireless interface, disabling multicast_to_unicast, etc (for example see here: https://forum.openwrt.org/t/clients-in- ... er/2501/78), but nothing seems to make any difference.

This evening I did a hard reset but clients still can't see each other and I'm running out of ideas....

If I connect to the Vocore (SSH or serial), I can ping each wireless client from there, but they just can't communicate with each other :/

Any idea on what's going on?

My (latest) wireless config (last two options are additions to try and solve the issue):

Code: Select all
config wifi-device 'ra0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'GB'
        option hwmode '11g'
        option htmode 'HT40'
        option channel 'auto'
        option disabled '0'

config wifi-iface 'ap'
        option device 'ra0'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option encryption 'psk2'
        option ssid 'some_ssid'
        option key 'some_password'
        option isolate 0
        option multicast_to_unicast 0

Vonger
 
Posts: 746
Joined: Sun Oct 19, 2014 6:00 am

Re: AP Isolation

Wed Aug 28, 2019 5:48 am

it should be firewall block each other.
You can modify /etc/config/firewall, set all to "ACCEPT", check if it works.

vaticanuk
 
Posts: 2
Joined: Tue Aug 27, 2019 8:37 pm

Re: AP Isolation

Wed Aug 28, 2019 7:14 pm

Everything in LAN is ACCEPT already:

Code: Select all
config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'


as per my previous post, the wifi is in the lan network :roll:

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 3 guests