Vocore2 ultimate and screen not easy

ArkEngr
 
Posts: 35
Joined: Tue Oct 20, 2015 1:58 pm

Vocore2 ultimate and screen not easy

Mon Sep 02, 2019 5:29 pm

I have tried many times but screen is still blank, here is log, any ideas ?
firmware 20190828.bin

[ 0.011901] console [tty0] enabled
[ 0.015173] bootconsole [early0] disabled
[ 0.019081] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[ 0.079084] pid_max: default: 32768 minimum: 301
[ 0.079355] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.079392] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.085232] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.085296] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.085440] pinctrl core: initialized pinctrl subsystem
[ 0.086040] NET: Registered protocol family 16
[ 0.117103] mt7621_gpio 10000600.gpio: registering 32 gpios
[ 0.117422] mt7621_gpio 10000600.gpio: registering 32 gpios
[ 0.117664] mt7621_gpio 10000600.gpio: registering 32 gpios
[ 0.123120] clocksource: Switched to clocksource MIPS
[ 0.129893] NET: Registered protocol family 2
[ 0.130805] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.130868] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.130917] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.131092] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.131150] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.131441] NET: Registered protocol family 1
[ 0.131509] PCI: CLS 0 bytes, default 32
[ 0.145658] Crashlog allocated RAM at address 0x3f00000
[ 0.147014] workingset: timestamp_bits=30 max_order=15 bucket_order=0
[ 0.152800] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.152896] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.163049] io scheduler noop registered
[ 0.163213] io scheduler deadline registered (default)
[ 0.164310] Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
[ 0.165682] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
[ 0.166488] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
[ 0.167293] 10000e00.uart2: ttyS2 at MMIO 0x10000e00 (irq = 30, base_baud = 2500000) is a 16550A
[ 0.572405] console [ttyS2] enabled
[ 0.576625] cacheinfo: Failed to find cpu0 device node
[ 0.581915] cacheinfo: Unable to detect cache hierarchy for CPU 0
[ 0.588956] spi-mt7621 10000b00.spi: sys_freq: 193333333
[ 0.607400] m25p80 spi0.0: w25q128 (16384 Kbytes)
[ 0.612329] 4 fixed-partitions partitions found on MTD device spi0.0
[ 0.618859] Creating 4 MTD partitions on "spi0.0":
[ 0.623798] 0x000000000000-0x000000030000 : "u-boot"
[ 0.629849] 0x000000030000-0x000000040000 : "u-boot-env"
[ 0.636251] 0x000000040000-0x000000050000 : "factory"
[ 0.642277] 0x000000050000-0x000001000000 : "firmware"
[ 0.725916] 2 uimage-fw partitions found on MTD device firmware
[ 0.732030] 0x000000050000-0x0000001cb5e5 : "kernel"
[ 0.738039] 0x0000001cb5e5-0x000001000000 : "rootfs"
[ 0.744025] mtd: device 5 (rootfs) set to be root filesystem
[ 0.751316] 1 squashfs-split partitions found on MTD device rootfs
[ 0.757746] 0x000000490000-0x000001000000 : "rootfs_data"
[ 0.764971] libphy: Fixed MDIO Bus: probed
[ 0.779191] rt3050-esw 10110000.esw: link changed 0x00
[ 0.787593] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[ 0.797989] NET: Registered protocol family 10
[ 0.806540] Segment Routing with IPv6
[ 0.810469] NET: Registered protocol family 17
[ 0.815175] 8021q: 802.1Q VLAN Support v1.8
[ 0.831563] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[ 0.839782] Freeing unused kernel memory: 168K
[ 0.844400] This architecture does not have kernel memory protection.
[ 2.220019] init: Console is alive
[ 2.223891] init: - watchdog -
[ 2.433840] random: fast init done
[ 5.359197] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[ 5.493041] usbcore: registered new interface driver usbfs
[ 5.498868] usbcore: registered new interface driver hub
[ 5.504481] usbcore: registered new device driver usb
[ 5.543780] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 5.559493] SCSI subsystem initialized
[ 5.568871] ehci-platform: EHCI generic platform driver
[ 5.584652] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
[ 5.591538] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
[ 5.596919] ehci-platform 101c0000.ehci: EHCI Host Controller
[ 5.602844] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[ 5.611119] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[ 5.643140] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[ 5.650640] hub 1-0:1.0: USB hub found
[ 5.654988] hub 1-0:1.0: 1 port detected
[ 5.662523] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 5.670693] ohci-platform: OHCI generic platform driver
[ 5.676430] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
[ 5.683477] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[ 5.691719] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[ 5.768217] hub 2-0:1.0: USB hub found
[ 5.772572] hub 2-0:1.0: 1 port detected
[ 5.789970] MTK MSDC device init.
[ 5.853354] mtk-sd: MediaTek MT6575 MSDC Driver
[ 5.866134] usbcore: registered new interface driver usb-storage
[ 5.876574] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 5.894661] init: - preinit -
[ 6.273653] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 6.554334] hub 1-1:1.0: USB hub found
[ 6.583669] hub 1-1:1.0: 4 ports detected
[ 7.171625] usb 1-1.1: new high-speed USB device number 3 using ehci-platform
[ 7.365182] rt3050-esw 10110000.esw: link changed 0x00
[ 7.550257] random: procd: uninitialized urandom read (4 bytes read)
[ 7.573245] usb 1-1.2: new low-speed USB device number 4 using ehci-platform
[ 7.823139] usb 1-1.3: new full-speed USB device number 5 using ehci-platform
[ 10.793591] mount_root: loading kmods from internal overlay
[ 10.845715] kmodloader: loading kernel modules from //etc/modules-boot.d/*
[ 10.854597] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
[ 11.536586] jffs2: notice: (508) jffs2_build_xattr_subsystem: complete building xattr subsystem, 9 of xdatum (2 unchecked, 7 orphan) and 20 of xref (7 dead, 0 orphan) found.
[ 11.553335] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[ 11.568457] block: extroot: not configured
[ 11.740823] jffs2: notice: (506) jffs2_build_xattr_subsystem: complete building xattr subsystem, 9 of xdatum (2 unchecked, 7 orphan) and 20 of xref (7 dead, 0 orphan) found.
[ 11.759240] mount_root: loading kmods from internal overlay
[ 11.808979] kmodloader: loading kernel modules from /tmp/overlay/upper/etc/modules-boot.d/*
[ 11.820681] kmodloader: done loading kernel modules from /tmp/overlay/upper/etc/modules-boot.d/*
[ 12.329780] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[ 12.341635] block: extroot: not configured
[ 12.347140] mount_root: switching to jffs2 overlay
[ 12.396074] overlayfs: upper fs does not support tmpfile.
[ 12.406888] urandom-seed: Seeding with /etc/urandom.seed
[ 12.548034] procd: - early -
[ 12.551156] procd: - watchdog -
[ 13.371135] procd: - watchdog -
[ 13.374766] procd: - ubus -
[ 13.527500] random: ubusd: uninitialized urandom read (4 bytes read)
[ 13.688513] random: ubusd: uninitialized urandom read (4 bytes read)
[ 13.695635] random: ubusd: uninitialized urandom read (4 bytes read)
[ 13.703221] procd: - init -
[ 14.081272] kmodloader: loading kernel modules from /etc/modules.d/*
[ 14.095137] fbusb 1-1.1:1.0: looking for new device.
[ 14.100533] usbcore: registered new interface driver fbusb
[ 14.200547] tun: Universal TUN/TAP device driver, 1.6
[ 14.212947] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 14.230181] i2c /dev entries driver
[ 14.238045] gdma-rt2880 10002800.gdma: revision: 3, channels: 16
[ 14.273821] i2c-mt7628 10000900.i2c: clock 100KHz
[ 14.296124] Linux video capture interface: v2.00
[ 14.312099] hidraw: raw HID events driver (C) Jiri Kosina
[ 14.324637] usb 1-1.1: USB disconnect, device number 3
[ 14.350225] ralink-i2s 10000a00.i2s: mclk 480KHz
[ 14.407233] asoc-simple-card sound: es8328-hifi-analog <-> 10000a00.i2s mapping ok
[ 14.855533] <-- RTMPAllocTxRxRingMemory, Status=0, ErrorValue=0x
[ 14.863187] <-- RTMPAllocAdapterBlock, Status=0
[ 14.879689] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device
[ 14.903586] usbcore: registered new interface driver cdc_acm
[ 14.909440] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 14.950087] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 15.006632] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
[ 15.163964] input: SIGMACHIP USB Keyboard as /devices/platform/101c0000.ehci/usb1/1-1/1-1.2/1-1.2:1.0/0003:1C4F:0016.0001/input/input0
[ 15.243489] hid-generic 0003:1C4F:0016.0001: input,hidraw0: USB HID v1.10 Keyboard [SIGMACHIP USB Keyboard] on usb-101c0000.ehci-1.2/input0
[ 15.292088] input: SIGMACHIP USB Keyboard as /devices/platform/101c0000.ehci/usb1/1-1/1-1.2/1-1.2:1.1/0003:1C4F:0016.0002/input/input1
[ 15.373481] hid-generic 0003:1C4F:0016.0002: input,hidraw1: USB HID v1.10 Device [SIGMACHIP USB Keyboard] on usb-101c0000.ehci-1.2/input1
[ 15.386534] usbcore: registered new interface driver usbhid
[ 15.392266] usbhid: USB HID core driver
[ 15.446169] xt_time: kernel timezone is -0000
[ 15.551043] PPP generic driver version 2.4.2
[ 15.558771] NET: Registered protocol family 24
[ 15.575346] usbcore: registered new interface driver snd-usb-audio
[ 15.590913] usbcore: registered new interface driver uvcvideo
[ 15.596890] USB Video Class driver (1.1.1)
[ 15.606328] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 16.033230] usb 1-1.1: new high-speed USB device number 6 using ehci-platform
[ 16.351127] fbusb 1-1.1:1.0: device detected.
[ 16.357663] Console: switching to colour frame buffer device 100x30
[ 16.507185] fbusb 1-1.1:1.0: fb0: mode=480x800x16.

Vonger
 
Posts: 754
Joined: Sun Oct 19, 2014 6:00 am

Re: Vocore2 ultimate and screen not easy

Fri Sep 06, 2019 3:06 pm

looks like the driver is normal, if the screen is normal you should able to see the logo.
there are two possible problems:

1. screen has two types, old types is marked vocore2 which is big endian to display 24bit color more quick, another one is marked djn1522(you can find the mark at back of the screen) little endina for fast display 16bit color. 20190828.bin embed driver is for djn1522, if your screen is 'vocore2' it won't work. need to recompile the driver. source code has upload to github.com/vonger/vocore2 and in package/utils/fbusb

2. If screen is still black, it should be backlight broken, please send a photo to support@vocore.io, we will ship you a new screen.

PS: I will try to make the driver more compatible for different screen later, so we do not have to recompile firmware for different type of screen...just change a parameter then it will work.

Vonger
 
Posts: 754
Joined: Sun Oct 19, 2014 6:00 am

Re: Vocore2 ultimate and screen not easy

Sat Sep 14, 2019 2:12 pm

try this firmware, it has default console to screen.
for screen marked 'djn1522': http://vonger.cn/misc/vocore2/20190914.bin
for screen marked 'vocore' : http://vonger.cn/misc/vocore2/20190914v2.bin

ArkEngr
 
Posts: 35
Joined: Tue Oct 20, 2015 1:58 pm

Re: Vocore2 ultimate and screen not easy

Sat Sep 14, 2019 6:39 pm

installed file
http://vonger.cn/misc/vocore2/20190914v2.bin

on boot a splash screen is displayed, then log file is displayed, but new lines are shown about 3 lines down from the
top, older lines start at about line 5 and below. Entering key strokes are displayed, but when entered, there is no action
taken on them, screen just does a carriage control and line feed. blinking dash for cursor is shown.

I found Texas Instruments has a chip DP83869HM that I am using to add a fiber interface to my vocore. trying to
see if I need all of the magnetics between the vocore and the DP83869 to make a simpler circuit board.

Nice to see my screen works though :)

ArkEngr
 
Posts: 35
Joined: Tue Oct 20, 2015 1:58 pm

Re: Vocore2 ultimate and screen not easy

Sat Sep 14, 2019 7:33 pm

redirecting from ssh to /dev/tty0 works, just have issues with usb keyboard not used by shell in tty0

Vonger
 
Posts: 754
Joined: Sun Oct 19, 2014 6:00 am

Re: Vocore2 ultimate and screen not easy

Sun Sep 15, 2019 1:56 am

first issue can be fixed by power off and reboot. that is because current driver do not have reset screen function.
second usb keyboard, it should be plugin and then ready to use, just need a usb hub, it already has hid driver installed.

ArkEngr
 
Posts: 35
Joined: Tue Oct 20, 2015 1:58 pm

Re: Vocore2 ultimate and screen not easy

Sun Sep 15, 2019 3:01 am

The keyboard types on the screen, but there is no shell such as bash running to interpret the text typed in.
See attachment. Otherwise I see how screen reset on reboot.
Attachments
smallScreen.jpg
smallScreen.jpg (69.56 KiB) Viewed 1071 times

ArkEngr
 
Posts: 35
Joined: Tue Oct 20, 2015 1:58 pm

Re: Vocore2 ultimate and screen not easy

Wed Sep 25, 2019 6:12 pm

I got the other model of Vocore Screen and I see a similar behavior, there is no shell process that the keyboard connects too. It just types on the screen.
Now I make a new problem, the usb power/console input says failPress Enter for Console each time you press enter after boot up.

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 2 guests