Hello, after compiling OpenWRT 19.07.3 the default configuration for vocore (without any patches from vocore github) the configuration is a transparent wireless bridge from wifi to ethenet. I dont like this as there seems no reasonable way to connect to the vocore from either wifi or network side - it does not have to have assigned IP address from the LAN DHCP server.
What is the correct procedure to change this - probably in OpenWRT sources? Which file defines the default OpenWRT Vocore network configuration?
Thanks for pointing me the right direction.
Marcel
VoCore2 / vanilla OpenWRT default configuration
- marcel22
- Posts: 3
- Joined: Wed Jun 24, 2020 2:35 pm
- Vonger
- Posts: 907
- Joined: Sun Oct 19, 2014 6:00 am
Re: VoCore2 / vanilla OpenWRT default configuration
I think this is a virtual network setting issue.
Default it is connect to lan, you can change it to wan, config file is at /etc/config/network, you can directly edit it, or use openwrt command uci, or use luci setting it.
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 6t'
this means port 0 is vlan 1
so vlan 1 map to eth0.1, vlan 2 map to eth0.2
so you can find the two setting:
config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
config interface 'wan'
option ifname 'eth0.2'
option force_link '1'
option proto 'dhcp'
lan is eth0.1(vlan 1) wan is eth0.2(vlan 2), and in wan setting it enables dhcp.
so just change one line we can fix such issue. more detail you can check openwrt.org.
config switch_vlan
option device 'switch0'
- option vlan '1'
+ option vlan '2'
option ports '0 6t'
Default it is connect to lan, you can change it to wan, config file is at /etc/config/network, you can directly edit it, or use openwrt command uci, or use luci setting it.
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 6t'
this means port 0 is vlan 1
so vlan 1 map to eth0.1, vlan 2 map to eth0.2
so you can find the two setting:
config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
config interface 'wan'
option ifname 'eth0.2'
option force_link '1'
option proto 'dhcp'
lan is eth0.1(vlan 1) wan is eth0.2(vlan 2), and in wan setting it enables dhcp.
so just change one line we can fix such issue. more detail you can check openwrt.org.
config switch_vlan
option device 'switch0'
- option vlan '1'
+ option vlan '2'
option ports '0 6t'
- marcel22
- Posts: 3
- Joined: Wed Jun 24, 2020 2:35 pm
Re: VoCore2 / vanilla OpenWRT default configuration
So I need to make this change before I compile the OpenWRT image so I believe I should change the package/base-files/files/bin/config_generate file in OpenWRT distribution?!
Also - call me stupid, but which eta interface is the P0 ethernet port mapped to by default in OpenWRT vanilla package? Where is this information defined? In DTS files?
Also - call me stupid, but which eta interface is the P0 ethernet port mapped to by default in OpenWRT vanilla package? Where is this information defined? In DTS files?
- Vonger
- Posts: 907
- Joined: Sun Oct 19, 2014 6:00 am
Re: VoCore2 / vanilla OpenWRT default configuration
no, you do not need to compile it, just need to modify the setting file at /etc/config/network after upgrade your vocore.
4 posts
Page 1 of 1
Who is online
Users browsing this forum: No registered users and 1 guest