Usage of GPIO pins in openwrt22.03

Posts: 2
Joined: Wed Dec 23, 2020 8:38 pm

Usage of GPIO pins in openwrt22.03

Thu Feb 23, 2023 9:27 am

In openwrt19.07 it worked to go into /sys/class/gpio and say 'echo “42” >export' to make the respective I/O pin available as a new directory gpio42.
Upgraded now to openwrt22.03. The above does not work anymore.
Still there is export and unexport file handles available, and three directories gpiochip416, 448 and 480.
I added the lines for pinctrl into the vocore2.dts file, no improvement.
I applied the old 0882-pinctrl-fix-gpio-name.patch, no improvement.
I selected in kernel_menuconfig the respective GPIO Support section and there the /sys/class/gpio interface as well as the MT7621 GPIO support in the memory mapped driver area. Still not working.

Any idea what to do?
thank you

Posts: 892
Joined: Sun Oct 19, 2014 6:00 am

Re: Usage of GPIO pins in openwrt22.03

Wed Mar 08, 2023 12:23 pm

I guess somebody modified the gpio driver source code.
So the problem must be in linux kernel(maybe has a reason)

Return to VoCore2/Lite/Ultimate

Who is online

Users browsing this forum: No registered users and 4 guests